UVa 10392 Factoring Large Numbers(分解因数)

One of the central ideas behind much cryptography is that factoring large numbers is computationallyintensive. In this context one might use a 100 digit number that was a product of two 50 digit primenumbers. Even with the fastest projected computers this factorization will take hundreds of years.

You don’t have those computers available, but if you are clever you can still factor fairly largenumbers.

Input

The input will be a sequence of integer values, one per line, terminated by a negative number. Thenumbers will fit in gcc’s long long int datatype, however scanf and printf do not appear to handlethis datatype correctly, so you must do your own I/O conversion.

Output

Each positive number from the input must be factored and all factors (other than 1) printed out. Thefactors must be printed in ascending order with 4 leading spaces preceding a left justified number, andfollowed by a single blank line.

Sample Input

90
1234567891
18991325453139
12745267386521023
-1

Sample Output

2335

1234567891

    3
    3
    13
    179
    271
    1381
    2423
    30971
    411522630413

题目描述:分解long long范围内的整数,时限3秒

显然普通的试除法复杂度达到根号N,至少10^9级别。在网上查了题解,有很多说至多一个质因数是比较大的(~10^7),不过在题目描述中并没有这一点。后来看到这个优化,思路是在尝试除法时不需要用原来的N开方作为上界,而是用部分分解之后余下的N开方。代码如下。UVa运行时间30ms。

/*
	PROG: UVa10392
*/

#include <cstdio>
#include <cmath>
using namespace std;

typedef long long LL;
int main(void) {
	LL n;
	while (scanf("%lld", &n), n >= 0) {
		for (LL i = 2, u = (LL)sqrt(n+1); i <= u; ++i) { //u为优化的上界
			if (n%i) continue;
			while (n%i==0) {
				printf("    %lld\n", i);
				n /= i;
			}
			u = (LL)sqrt(n+1);
		}
		if (n > 1) printf("    %lld\n", n);
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值