Problem E: 逆序链表练习记录

Description

建立逆序链表并输出结果

Input

一组数字 以0结束

Output

链表内容

Sample Input

1 2 3 0

Sample Output

3 2 1 

上代码:

//非常简单的链表,注意最后倒序输出时起点是n-1,否则会导致数据溢出
#include<iostream>
using namespace std;
struct list {
	int data;
	list *next;
};

void createlist(list*& head) {
	list* p=NULL;
	list* s=NULL;
	s = new list;
	cin >> s->data;
	while (s->data != 0) {
		if (head == 0)
			head = s;
		else
			p->next = s;
		p = s;
		s = new list;
		cin >> s->data;
	}
	p->next = NULL;
	delete s;
	return;
}

void showlist(list* head,int a[])
{
	int n = 0;
	while (head) {
		a[n] = head->data;
		head = head->next;
		n++;
	}
	for (int i = n - 1; i >= 0; i--) {
		cout << a[i] << " ";
	}
	cout << endl;
}

int main() {
	list* head = NULL;
	int a[100] = {};
	createlist(head);
	showlist(head, a);
}

  • 7
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值