POJ - 3278 Catch That Cow(BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 97233 Accepted: 30516

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:给一个n,n只能+1,-1,*2. 问最少多少次运算,能等于k。

解决:抽象成BFS。(递归做也行)。

细节:一直内存超限。后来加了vis数组,记录这个数有没有计算过,避免很多重复运算。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#define fin freopen("in.txt", "r", stdin)
#define line printf("\n-----------------\n")
#define rearr(a,n) for(int i=0;i<n;i++)scanf("%d",&a[i]);
using namespace std;
const long long mod = 1000000007;
const int maxn = 100000+ 5;

int n , k, ans;
int vis[2 * maxn];
struct Point{
    int n, cnt;
}s, e;

queue<Point> q;
int bfs(int n){

    while(!q.empty()) q.pop();
    s.n = n; s.cnt = 0; vis[n] = 1;
    q.push(s);
    while(!q.empty()){
        s = q.front(); q.pop();
        if(s.n == k) {return s.cnt;}
        for(int i = 0; i < 3; i++){
            if(i == 0 && s.n < k && !vis[s.n + 1]){
                e.n = s.n + 1; e.cnt = s.cnt + 1; q.push(e); vis[s.n + 1] = 1;
            }
            else if(i == 1 && s.n >= 1 && !vis[s.n - 1]){
                e.n = s.n - 1; e.cnt = s.cnt + 1; q.push(e); vis[s.n - 1] = 1;
            }
            else if(i == 2 && s.n < k && !vis[s.n * 2]){
                e.n = s.n * 2; e.cnt = s.cnt + 1; q.push(e); vis[s.n * 2] = 1;
            }
        }
    }
    return -1;
}

int main(){
    while(cin >> n >> k){
        memset(vis, 0, sizeof(vis));
        if(n >= k) cout << n - k << endl;
        else cout << bfs(n) << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值