HDU2053Switch Game

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13114    Accepted Submission(s): 7971


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
Hint
hint
Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
 

Author
LL
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   2051  2052  2056  2054  2057 
 
            简单题:题目乍一看好像很难,但再仔细看看题不难发现其实第n个灯泡在第n次操作后的状态都是基于其之前的因子数个数,那问题到这边很简单了。
求因子数个数如果实在不会,由于本题的数据并不大,大可暴力检索。这里我用到的是将1000000范围内整数因子数统一打表,在不包含自身的条件下:
如果因子数个数为奇数输出 0 即可!如果不是就输出 1
#include<iostream>
#include<cstring>
#define N 1000000
using namespace std;
int dp[N];
void gcd()
{
    memset(dp,0,sizeof(dp));
    int i,j;
    int m=N/2;
    for(i=1;i<m;i++)
    for(j=i+i;j<N;j=j+i)
      dp[j]++;
}
int main(){
	gcd();
	int n;
    while(cin>>n){
    	if(dp[n]%2) cout<<"0"<<endl;
    	else cout<<"1"<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值