POJ1979 Red and Black (DFS)

       搜索听学长们是经常谈论的,由于一开始都是在做很水很水的题目,这种类型的题倒也是初次接触。此题还是比较简单的,利于我们这种初学者上手。

题目的大意是说给你一个N*M的字符矩阵,‘#’为墙不可走、‘@’为起点。问你现在从这一点我们遍历全图、在不走回头路的前提下最多走多少步。

题目意思一明白实现就简单多了(英语实在是差,能看实例分析出题意的题实在是少啊。。。)、用一个V[ ]数组来判断某点是否走过、避免走回头路。

在处理的过程中还要要注意的便是边界的判断,如果是初次做很容易就会超界。

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 26238 Accepted: 14249

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

#include<iostream>
#include<cstring>
#include<string>
#define N 25

using namespace std;
int w,h,startx,starty,count;
int v[N][N];
char arr[N][N];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};//定义某点可走的四个方向 
void DFS(int x,int y){
	for(int i=0;i<4;i++){
		int mx=x+dir[i][0];
		int my=y+dir[i][1];
		if(arr[mx][my]=='.'&&v[mx][my]==0&&mx>=0&&mx<w&&my>=0&&my<h){
			v[mx][my]=1;
			count++;
			DFS(mx,my);
		}
	}
}
int main(){
	int i,j;
	while(cin>>h>>w,w||h){
		memset(v,0,sizeof(v));
		for(i=0;i<w;i++)
		  for(j=0;j<h;j++)
		   {
		   	    cin>>arr[i][j];
		   	    if(arr[i][j]=='@')
		   	    {
		   	    	startx=i;
		   	    	starty=j;
				   }
			} 
		count=1;
		v[startx][starty]=1;
		DFS(startx,starty);
		cout<<count<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值