题目:
Description
Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.
ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.
Output
For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.
Sample Input
3
24 1
4358 754
305 794
Sample Output
34
1998
1
题意就是把两个数的每位交换之后求和,和然后在交换过来,要去掉前道0;具体题意看题目吧;比如 305 794 就求503+497=1000,然后到过来0001,去掉前到0,则变为1;
我是用一个字符串处理一下的,就很容易处理了;代码如下:
#include<iostream>
#include<fstream>
#include<iomanip>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<sstream>
#include<cassert>
using namespace std;
#define LL __int64
void Add(char *str1, char *str2, char *str3) {
// str3 = str1 + str2;
int i, j, i1, i2, tmp, carry;
int len1 = strlen(str1), len2 = strlen(str2);
char ch;
i1 = len1-1;
i2 = len2-1;
j = carry = 0;
for( ; i1 >= 0 && i2 >= 0; ++j, --i1, --i2 ) {
tmp = str1[i1]-'0'+str2[i2]-'0'+carry;
carry = tmp/10;
str3[j] = tmp%10+'0';
}
while( i1 >= 0 ) {
tmp = str1[i1--]-'0'+carry;
carry = tmp/10;
str3[j++] = tmp%10+'0';
}
while( i2 >= 0 ) {
tmp = str2[i2--]-'0'+carry;
carry = tmp/10;
str3[j++] = tmp%10+'0';
}
if( carry ) str3[j++] = carry+'0';
str3[j] = '\0';
for( i=0, --j; i < j; ++i, --j ) {
ch = str3[i];
str3[i] = str3[j];
str3[j] = ch;
}
}
int main() {
int t;
cin>>t;
char n[100],m[100];
while(t--) {
memset(n,'0',sizeof(n));
memset(m,'0',sizeof(m));
cin>>n>>m;
int l1=strlen(n);
int l2=strlen(m);
char n1[100];
char m1[100];
memset(n1,0,sizeof(n1));
memset(m1,0,sizeof(m1));
int i;
for(i=l1-1; i>=0; i--) {
if(n[i]!='0')
break;
}
int k=0;
for(i; i>=0; i--,k++) {
n1[k]=n[i];
}
for(i=l2-1; i>=0; i--) {
if(m[i]!='0')
break;
}
k=0;
for(i ; i>=0; i--,k++) {
m1[k]=m[i];
}
char ans[100];
Add(n1,m1,ans);
// cout<<n1<<endl;
// cout<<m1<<endl;
// cout<<ans<<endl;
int l3=strlen(ans);
for(i=l3-1; i>=0; i--) {
if(ans[i]!='0')
break;
}
memset(m1,0,sizeof(m1));
k=0;
for(i ; i>=0; i--,k++) {
m1[k]=ans[i];
}
cout<<m1<<endl;
}
return 0;
}