poj3150 Cellular Automaton

Description

cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers nmd, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output

sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2
 
 
矩阵的快速幂的问题:
利用矩阵A,B具有a[i][j]=A[i-1][j-1],B[i][j]=B[i-1][j-1](i-1<0则表示i-1+n,j-1<0则表示j-1+n)
我们可以得出矩阵C=a*b也具有这个性质
C[i][j]=sum(A[i][t]*B[t][j])=sum(A[i-1][t-1],B[t-1][j-1])=sum(A[i-1][t],B[t][j-1])=C[i-1][j-1]

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 505;
typedef long long llg;

int n, m, d, k;
llg a[N], b[N], c[N], tmp[N];

void multiply(llg a[], llg b[], llg c[]) {
    int j, k;
    for(j = 1; j <= n; j++) {
        tmp[j] = 0;
        for(k = 1; k <= n; k++)
            tmp[j] += a[k]*b[k>j-1? k-j+1:k-j+1+n];
    }
    for(j = 1; j <= n; j++)
        c[j] = tmp[j]%m;
}

void solve() {
    while(k) {
        if(k & 1)
            multiply(a, b, a);
        multiply(b, b, b);
        k >>= 1;
    }
}

int main() {
    int i;
    scanf("%d%d%d%d", &n, &m, &d, &k);
    for(i = 1; i <= n; i++)
        scanf("%I64d", &a[i]);
    for(b[1] = i = 1; i <= d; i++)
        b[i+1] = b[n+1-i] = 1;
    solve();
    for(i = 1; i < n; i++)
        printf("%I64d ", a[i]%m);
    printf("%I64d\n", a[n]%m);
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值