ZOJ 3471 状压DP

Most Powerful

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22

 

状压DP的第三道题,也许我是历史上把这题写的最复杂的人了。。。但是是没有看过题解写的,这让我感到些许欣慰。。。

 

题意:有若干个原子,每两个原子碰撞,都会有一个原子消失,并且释放出一定的能量,要求出这些原子最后变成一个后能释放的最大能量。

 

我的脑残思路:用DP[i][j]表示已经有i个原子发生碰撞后能产生的最大能量,状态转移方程就是DP[i][j] = max{DP[i-1][k]+maxval(p, j), DP[i][j]};

其中k能够转移得到j,p表示由k转移到j的过程中消失的原子,maxval(p, k)通过状态j找出在j状态时还没有消失的原子,用这些原子逐一碰撞原子p,返回碰撞可能产生的最大值,

如何判断状态k能够转移成状态j(我这里的状态用1表示碰撞过,0表示没碰过)?用他俩做异或运算,如果结果中1的数量不等于1,就说明不能转移;又如果k状态中1的数目小于等于1,也不能转移(原子碰撞至少要两个原子),又如果j中1的个数比k多1,也不能转移。

 

调试的辛酸,就不说了,这么复杂的思路。。。

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>


#define MAXN 1000010
#define INF 2100000000
#define esp 1e-6
using namespace std;

int mat[11][11];
int dp[(1<<11)][(1<<11)];
int state[11][(1<<11)];//1的数量为I的状态
int cnts[11];
int top[11];
int n;
int getnum(int x)
{
    int cnt = 0;
    while(x != 0)
    {
            cnt += (x & 1);
            x >>= 1;
    }
    return cnt;
}
int getnum0(int x)
{
    return n-getnum(x);
}
int canmove(int state1, int state2)
{
    int temp = state1^state2;
    int bit = 0;
    if(getnum(temp) != 1) return -1;
    if(getnum0(state1) <= 1) return -1;
    else
    {
        while(temp != 0)
        {
            if(temp&1)
            {
                if(((1 << bit) && state2) == 0) return -1;
                return bit;
            }
            bit++;
            temp >>= 1;
        }

    }
}
int maxval(int st, int p)
{
    int temp[11], cntt  = 0;
    int bit = 0;
    while(bit < n)
    {
        if(!(st&1)) temp[cntt++] = bit;
        bit++;
        st >>= 1;
    }

    int maxv = 0;
    for(int i = 0; i < cntt; i++)
    {
        maxv = max(maxv, mat[temp[i]][p]);
    }
    return maxv;

}
int main()
{
    //freopen("C:/Users/Admin/Desktop/in.txt", "r", stdin);

    memset(cnts, 0, sizeof(cnts));
    for(int j = 0; j < (1<<10); j++)
    {
        state[getnum(j)][cnts[getnum(j)]++] = j;
    }



    while(cin >> n && n)
    {
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
            {
                cin >> mat[i][j];
            }
        }
        memset(dp, 0, sizeof(dp));

        for(int i = 0; i <= n; i++)
        {
            for(int j = 0; j < cnts[i]; j++)
            {
                if(state[i][j] >= (1 << n)) break;
                top[i] = j+1;
            }
        }

        for(int i = 1; i < n; i++)
        {
            for(int j = 0; j < top[i]; j++)
            {
                for(int k = 0; k < top[i-1]; k++)
                {
                    int p = canmove(state[i-1][k], state[i][j]);
                    if(p != -1)
                    {
                            dp[i][state[i][j]] = max(dp[i-1][state[i-1][k]] + maxval(state[i][j], p), dp[i][state[i][j]]);
                    }
                }
            }
        }
        int maxv = 0;
        for(int i = 0; i < top[n-1]; i++) maxv = max(maxv, dp[n-1][state[n-1][i]]);

        cout << maxv << endl;
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值