POJ 2528 线段树+离散化

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40934 Accepted: 11911

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4


题意:有一些海报,高度铺满整个墙,给出每个海报所占的左右区间(按照贴放海报的顺序给出),求出能看到的海报的张数。


思路:构造一颗线段树,线段树维护当前的线段是否被完全覆盖。从后向前扫描海报,每次扫描后先判断海报所在区间在线段树中是否被完全覆盖,如果没有,说明能够看到这张海报,令总数量+1,并把海报的区间代表的线段插入线段树;否则就退出。之所以能这样做是因为后面的海报总在上方,如果加入前面的海报时区间已被覆盖,那么这张海报肯定会被后面的海报遮住。


还有数据范围很大,需要进行离散化处理,但是看到别人人的题解,该题中的每个点代表一个小区间,单纯离散化有BUG,如果相邻两个点的坐标差大于1,应该插入一个坐标位于这两点的坐标之间的点。(这个 我也是看了别人的题解才知道,所以就不详细说了)


代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>

using namespace std;

# pragma comment (linker,"/STACK:16777216")

const int MAXN = 50010;
const int INF = 2100000000;

int n;
int a[MAXN], cnt;
int b[MAXN];
bool tree[MAXN*4];

struct Node
{
    int left, right;
} node[MAXN];

bool ins(int p, int l, int r, int x, int y)
{
    bool ok = 0;

    if(l != r && tree[p])
    tree[p<<1] = tree[(p<<1)+1] = 1;

    if(b[l] <= x && b[r] >= y)
    {
        if(tree[p]) return 0;
    }

    if(x <= b[l] && y >= b[r])
    {
        if(tree[p]) return 0;
        tree[p] = 1;
        if(l != r)
        {
            tree[p<<1] = 1;
            tree[(p<<1)+1] = 1;
        }

        return 1;
    }

    int mid = (l+r) >>1;

    if(x <= b[mid]) ok = ins(p*2, l, mid, x, y) || ok;
    if(y > b[mid]) ok = ins(p*2+1, mid+1, r, x, y) || ok;

    if(tree[p<<1] && tree[(p<<1)+1]) tree[p] = 1;

    return ok;
}
int main()
{
   //freopen("C:/Users/zts/Desktop/in.txt", "r", stdin);
    int t;
    scanf("%d", &t);
    while(t--)
    {
        memset(tree, 0, sizeof(tree));
        cnt = 0;
        scanf("%d", &n);
        int x, y;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &x, &y);
            node[i].left = x;
            node[i].right = y;

            a[cnt++] = x;
            a[cnt++] = y;
        }

        sort(a, a+cnt);
        b[1] = a[0];
        int cnt2 = 2;
        for(int i = 1; i < cnt; i++)
        {
            if(a[i] == a[i-1]) continue;

            if(a[i] - a[i-1] > 1)
            b[cnt2++] = a[i]-1;

            b[cnt2++] = a[i];
        }

        int ans = 0;

        for(int i = n-1; i >= 0; i--)
        {
            ans += ins(1, 1, cnt2-1, node[i].left, node[i].right);
        }

        printf("%d\n", ans);
    }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值