HDU 3746



Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3931    Accepted Submission(s): 1768


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3 aaa abca abcde
 

Sample Output
  
  
0 2 5
 

Author
possessor WC
 

Source
 

Recommend
lcy


题意:
给出一个字符串,问至少在首或尾添加几个字符能使其能够由其某个字串拼接而来。

思路:
维护出KMP的next数组,考虑最后一个字符的next值,分三种情况:
1.next值为-1,说明需要添加len个字符(len为字符长度)
2.next值<=(len)/2-1,说明字符串首尾有部分是相同的,只需添加不相同部分的字符个数
3.next值>(len)/2-1,说明字符串首尾子串有部分相同,但首尾子串有重叠,设la = next[len-1]+1, lb = len-la,若lb%la == 0,说明字符串可由lb的这部分构成,
否则,需要在字符串首部添加 (lb - lb%la)%lb个字符。


代码:
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

#define N 210
#define M 50000
#define INF 1000000000

char str[100100];
int nxt[100100], len;
void getNext()
{
    nxt[0] = -1;
    int p;
    for(int i = 1; i < len; i++)
    {
        p = nxt[i-1];
        for(; p >= 0 && str[p+1] != str[i]; p = nxt[p]);
        p = str[p+1] == str[i] ? p+1 : -1;
        nxt[i] = p;
    }
}

int main()
{
	//freopen("C:\\Users\\zfh\\Desktop\\in.txt", "r", stdin);
    int n;
    while(scanf("%d", &n) != -1)
    {
        for(int i = 0; i < n; i++)
        {
            scanf(" %s", str);
            len = strlen(str);
            getNext();

            int p = nxt[len-1], ans;

            if(p == -1)
            {
                ans = len;
            }
            else if(p+1 <= len/2)
            {
                ans = len-(p+1)*2;
            }
            else
            {
                int la = p+1, lb = len-la;
                int temp = la%lb;
                ans = (lb-temp);
                if(ans == lb) ans = 0;
            }

            printf("%d\n", ans);
        }

    }
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值