Strange fuction

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 简单题意:
  给出一个方程F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x,然后求出指定范围内的最小值。
解题思路形成过程:
  这和第一题极其类似,也是用二分法实现解题。但是需要强大的数学知识储备,我也是过了好久,才用到求导这个方法。
感想:
  算法,果然还是离不开数学储备。
AC代码:
 
#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
const double n=1e-6;
int t;
double y;
double f1(double x)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f2(double x)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}

using namespace std;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&y);
        double ll=0,rr=1e2,mid;
        while(ll+n<=rr)
        {
            mid=(ll+rr)/2;;
            if(f2(mid)>0) rr=mid;
             else ll=mid;
        }
        printf("%.4f",f1(mid));
        cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值