Xcode支持iOS6、iOS7版本

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tao767992245/article/details/52910390

Xcode升级到8.0版本后,默认只支持iOS8.0了,这时无法支持iOS8.0以下的版本了,同时项目编译时会出现一大堆的黄色警告,警告的内容是一些方法已经被弃用了,但是这些方法是可以正常使用的,只是说未来的某一天不能使用,但编译器不知道,如果项目紧急上线不想改,但又不想出现这些警告,那怎么办?烦人!其实在iOS7的时候不会出现这些警告,所以只要让我们的项目兼容到iO7、iOS6就可以了。

下载Xcode支持的平台版本,这是别人网盘分享出来的,非常感谢这位仁兄,里面包含iOS6.0及以上版本
地址: https://pan.baidu.com/s/1dFaAqzf
下载后的结果如下:
这里写图片描述

然后把自己需要支持的版本拷贝到Xcode的DeviceSupport目录
步骤:Finder->应用程序->Xcode->右击,显示包内容 就能看到Contents目录了,然后按照下面步骤逐步打开,就能看到想看的文件
“/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport”
这里写图片描述

修改SDKSettings.plist文件
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/SDKSettings.plist
DefaultProperties -> DEPLOYMENT_TARGET_SUGGESTE 该数组中添加 6.0 6.1 7.0 7.1
这里写图片描述
在这里要注意一下,你在添加的时候可能出现无法添加,没有权限等提示,不用担心,回到上面的Contents目录,右击显示简介,图片如下:这里写图片描述
点击左下角的+号,添加当前用户,权限改成读与写,接着点击左下角的齿轮按钮,选择:应用到包含的项目,OK,重启Xcode,这时你就发现你可以添加了,添加好了之后,重新启动Xcode,大功告成,现在就可以在”Deployment Target”中选择需要支持的最低平台了。
这里写图片描述

最后也要谢谢@skylin19840101,http://blog.csdn.net/skylin19840101/article/details/52840622,我也是从他这里学习的,然后把自己在操作过程中遇到的问题再完善了一下。

阅读更多 登录后自动展开
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页