HIT1003 Mixing Milk

Description
Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer’s limit.

Given the Merry Milk Makers’ daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers’ requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

Input
The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers’ want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

Output
A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

Sample Input
100 5
5 20
9 40
3 10
8 80
6 30
Sample Output
630
Solution

#include <iostream>
#include <cmath>
#include <algorithm>
#include <iomanip>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

int n,m;

struct Node{
    int p;
    int a;
}f[5005];

bool cmp(Node a,Node b){
    if (a.p < b.p)return 1; else return 0;
}

int main(){
    int cnt=0;
    scanf("%d%d",&n,&m);
    for (int i=1;i<=m;++i){
        scanf("%d %d",&f[i].p,&f[i].a);
    }
    sort(f+1,f+1+m,cmp);
    for (int i=1;i<=m && n > 0;++i){
        if ((f[i].a) <= n){
            n-=(f[i].a);
            cnt +=   (f[i].a)*(f[i].p);
        }
        else{
            cnt += n * f[i].p;
            n = 0;
        }
    }
    printf("%d\n",cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
#include void swap(int *a, int *b) //swap()函数实现交换两个数组元素的值的功能。 { int t=*a; *a=*b; *b=t; } void qsort(int arr[],int left,int right) //qsort()函数实现快速排序,并且是递归调用,而且,递归调用qsort()函数本身两次,因为要对中值两边的 { //部分分别进行排序。arr是待排序的数组名,left是排序的左边界,第一次调用时,是整个数组最左边元素的序号,通常 //为0,right是排序的右边界,第一次调用时,是整个数组最右边元素的序号,如果数组长度为n,right通常为 n-1. int i = left; //用i从左边开始扫描数组。 int j = right; //用j从右边开始扫描数组。 int key = arr[(i+j)/2]; //先设置一个基准值key,此程序是以数组的中间位置的元素为基准值。 while(i =j时,i所指向的数组元素,都是j已经访问,判断过的元素,不用再用i去访问,判断了。 { for(;(i < right)&&(arr[i] < key);i++); /*当i<right,且,arr[i]<key时,表示,还没有找到要放到key右边的元素,或者,i还没有指到数组 的右边第二个元素,则,i++,继续找。此处,为什么是i<right,而不是i<(i+j)/2(基准值key的下标),因为, key现在的位置不一定是它此轮排序的最终位置,所以是整个数组拉通交换排序,所以,i除了最右边一个元素外,数组其它 元素都要访问,所以必须是i<right。 i<=right, 也能实现功能,但是,i left)&&(arr[j] > key);j--); /*当j>left,且,arr[j]>key时,表示,还没有找到要放到key左边的元素,或者,j还没有指到数组的左边第 二个元素,则,j--,继续找。此处,为什么是j>left,而不是i>(i+j)/2(基准值key的下标),因为,key现在的 位置不一定是它此轮排序的最终位置,所以整个数组拉通交换排序,所以,j除了最左边一个元素外,数组其它元素都要访问, 所以必须是j>left。 j>=left, 也能实现功能,但是,j>left,少循环一次,程序执行更快,而且,因为i初值为left, 所以已经用i访问,判断过left元素是否需要移动了,不需要再用j来访问,判断了。*/ //注意,此处,是两个for循环执行完了以后,再执行下面的交换操作。即,左,右两边都找到了需要移动的元素后,再互相交换位置。 if (i <= j) //此处改成i<j的话,程序会出错。至于为什么,可以看程序末尾的解释。 {
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值