数据大搜索
写一个程序,把一个字符串中的数字子序列找出来并转换成十进制整数输出。
Input
第一行是整数nn,表示测试的数据组数,下面是nn行无空格的字符串(长度不超过200)。题目保证字符串中含的整数位数小于99位,不考虑负数情形。
Output
每一行输入对应一行输出,一行中若有多个数据,每个数据后有一个空格。
Sample Input
1 00tUrA-Hc:T#7yN`;J0123Y+'-rD%\SV`{)e'9;Lt[^$}~0Sample Output
0 7 123 9 0
getchar() 的处理
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
char s[250];
int a[250];
int main()
{
int n, i, j, len, p;
scanf("%d", &n);
char aaa[250];
gets(aaa); //getchar();getchar();
while(n--)
{
gets(s);
len = strlen(s);
int x = 0;
for(i = 0; i < len + 1; i++)
{
if(s[i] >= '0' && s[i] <= '9')
{
p = 0;
for(j = i; j < len + 1; j++)
{
if(s[j] >= '0' && s[j] <= '9')
{
p = p*10 + s[j] - '0';
}
else
{
i = j;
a[x++] = p;
break;
}
}
}
}
for(i = 0; i < x; i++)
printf("%d ", a[i]);
printf("\n");
}
return 0;
}
Status | Accepted |
---|---|
Time | 2ms |
Memory | 256kB |
Length | 907 |
Lang | C |
Submitted | 2018-08-25 09:32:01 |
Shared | |
RemoteRunId | 432408 |