1097 Deduplication on a Linked List (25 point(s))
Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Key Next
where Address
is the position of the node, Key
is an integer of which absolute value is no more than 104, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
题目大意:去除链表的重复绝对值元素然后输出去除后的链表和删除后的元素。
解题思路:简单模拟。
#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
struct node {
int address;
int key;
int next;
}s[100005];
vector<node> res1;
vector<node> res2;
map<int, int> a;//记录次数
map<int, int> b;//记录add-key
map<int, int> c;//记录add-next
int main()
{
int start, n;
scanf("%d %d", &start, &n);
if (n == 1) {
int hh, gg, kk;
scanf("%d %d %d", &hh, &gg, &kk);
printf("%05d %d -1\n", hh, gg);
}
else {
for (int i = 0; i < n; i++) {
node cur;
scanf("%d %d %d", &cur.address, &cur.key, &cur.next);
b[cur.address] = cur.key;
c[cur.address] = cur.next;
/*if (a[abs(cur.key)] == 0) {
a[abs(cur.key)] += 1;
res1.push_back(cur);
}
else {
res2.push_back(cur);
}*/
}
while (start != -1) {
node cur;
cur.address = start;
cur.key = b[start];
cur.next = c[start];
if (a[abs(cur.key)] == 0) {
a[abs(cur.key)] += 1;
res1.push_back(cur);
}
else {
res2.push_back(cur);
}
start = cur.next;
}
for (int i = 0; i < res1.size(); i++) {
if(i!=res1.size()-1)
printf("%05d %d %05d\n", res1[i].address, res1[i].key, res1[i + 1].address);
else
printf("%05d %d -1\n", res1[i].address, res1[i].key);
}
for (int i = 0; i < res2.size(); i++) {
if(i!=res2.size()-1)
printf("%05d %d %05d\n", res2[i].address, res2[i].key, res2[i + 1].address);
else
printf("%05d %d -1\n", res2[i].address, res2[i].key);
}
}
return 0;
}