二分查找1

10 篇文章 0 订阅

zcmu:
1099: 查找元素II
Time Limit: 1 Sec Memory Limit: 128 MB

[Submit][Status][Web Board]
Description

给定一个整数集合s,集合中有n个元素,我有m次询问,对于每次询问给定一个整数x,若 x存在于集合s中输出x found at y,y为集合s按从小到大排序后第一次出现x的下标,否则输出x not found.

Input

多组测试数据,每组第一行为两个正整数n,m.(1<=n,m<=1000)代表集合中元素的个数和查询次数,接下来n行每行有一个正整数代表集合里的元素.(每个整数的大小小于等于100000),接下来 m行每行有一个正整数代表查询的元素.

Output

详见sample output

Sample Input

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3

Sample Output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

HINT

Source
//好久前写的,现在拿出来当总结
Ac_code~:

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[1005],b[1005];
int search2(int aim,int a[],int l)//二分法查找
{
    int top=0,tail=l-1,z,f=-1;
    while(top<=tail)
    {
        z=(tail+top)/2;
        if(aim<a[z])
        {
            tail=z-1;
        }
        else if(aim>a[z])
        {
            top=z+1;
        }
        else
        {
            f=z;
            break;
        }
    }
    return f;
}
int main()
{
    int n,m,k=0;
    while(~scanf("%d%d",&n,&m))
    {
        k++;
        int i,j,w;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        for(j=0; j<m; j++)
        {
            scanf("%d",&b[j]);
        }
        printf("CASE# %d:\n",k);
        for(i=0; i<m; i++)
        {
            w=search2(b[i],a,n);//查询到返回数组下标值,否知返回的为-1
            if(w==-1) printf("%d not found\n",b[i]);
            else
            {
                for(j=w-1; j>=0; j--)
                {
                    if(a[w]!=a[j]) break;
                    else w=j;
                }
                printf("%d found at %d\n",b[i],w+1);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值