不分大小写的Strstr

1614: Problem 3
Time Limit: 1 Sec Memory Limit: 128 MB
[Submit][Status][Web Board]
Description

fjxmlhx hates marshtomp, so he wants to ignore the “marshtomp” in every sentences. In order to making the sentence complete, he changes the word “marshtomp” into “fjxmlhx”

please create a class, then you must solve the problem via calling the method of the class with the object of the class.

Input

the input contains several lines

each line there exists a string whose length is no more than 200

Attention: the end of line has nothing to do with the beginning of the next line

Output

print the answer of the problem

Sample Input

marshTomp is beaten by fjxmlhx!
AmarshtompB

Sample Output

fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

HINT

Source
/*
对于C语言有分大小写的子串查找函数strstr,对于这题用strstr解决不了,因为它的子串匹配根据样例输出可以看出是不分大小写的,所以我就(借助不分大小写的比较函数strncasecmp和指针)自己写了个不分大小写的子串匹配函数,我叫它Strstr。
*/
AC_code:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char *Strstr(char *a,const char *b)
{
    int len_b = strlen(b);
    while(*a)
    {
        if(strncasecmp(a,b,len_b)==0)
        {
            return a;
        }
        a++;
    }
    return NULL;
}
int main()
{
    char a[205];
    while(gets(a))
    {
        int len = strlen(a);
        char *p = a;
        const char *q ="marshTomp",*f = "fjxmlhx";
        while(Strstr(p,q))
        {
            char *start = Strstr(p,q);
            *start = '\0';
            *(start+1) = '\0';
            strncpy(start+2,f,7);
            p++;
        }
        for(int i = 0; i < len; i++)
        {
            if(a[i]!='\0')
                printf("%c",a[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值