1799: Problem C: Primary Arithmetic

1799: Problem C: Primary Arithmetic
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 153 Solved: 49
[Submit][Status][Web Board]
Description

Problem C: Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the “carry” operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0. For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Input

Output

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.

HINT

Source
/*
注意进位只有一次的时候是打印“operation”,而不是“operations”!
*/
Ac_code:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char a[15],b[15],c[30];
int main()
{
    while(~scanf("%s %s",a,b))
    {
        if(a[0]=='0'&&b[0]=='0') break;
        int lenth_a = strlen(a);
        int lenth_b = strlen(b);
        int def,flag = 0;
        memset(c,'\0',sizeof(c));
        if(lenth_a > lenth_b)
        {
            flag = 1;
            def = lenth_a - lenth_b;
            fill(c,c+def,'0');
            strcat(c,b);
        }
        else
        {
            def = lenth_b - lenth_a;
            fill(c,c+def,'0');
            strcat(c,a);
        }
        int carrybit = 0,x,y,time = 0,num;
        for(int i = max(lenth_a,lenth_b); i >= 0; i--)
        {
            if(flag)
                x = a[i] - '0';
            else
                x = b[i] - '0';
            y = c[i] - '0';
            num = x + y + carrybit;
            if(num >= 10)
            {
                carrybit = num/10;
                time++;
            }
            else
                carrybit = 0;
        }
        if(time)
        {
            if(time > 1)
                printf("%d carry operations.\n",time);
            else
                printf("%d carry operation.\n",time);
        }
        else
            printf("No carry operation.\n");
        memset(a,'0',sizeof(a));
        memset(b,'0',sizeof(b));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值