HDU 3530 Subsequence(单调队列)

Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 29   Accepted Submission(s) : 17

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Input

There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.

Output

For each test case, print the length of the subsequence on a single line.

Sample Input

5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5

Sample Output

5
4
#include<iostream>
#include<deque>
using namespace std;
int a[500000];
int main(){
    ios::sync_with_stdio(false);
    int n,m,k;
    deque<int>q1;
    deque<int>q2;
    while(cin>>n>>m>>k){
        for(int i=1;i<=n;i++){
            cin>>a[i];
        }
        while(!q1.empty()){q1.pop_front();}
        while(!q2.empty()){q2.pop_front();}
        int last=0;
        int ans=0;
        for(int i=1;i<=n;i++){
            while(!q1.empty()&&a[i]>=a[q1.back()]){q1.pop_back();}//从大到小
            while(!q2.empty()&&a[i]<=a[q2.back()]){q2.pop_back();}//从小到大
            q1.push_back(i);
            q2.push_back(i);
            while(!q1.empty()&&!q2.empty()&&a[q1.front()]-a[q2.front()]>k){ //当q1-q2>k时,重新选择区间
                if(q1.front()>q2.front()){ //缩小区间
                    last=q2.front();
                    q2.pop_front();
                }else{
                    last=q1.front();
                    q1.pop_front();
                }
            }
            if(!q1.empty()&&!q2.empty()&&a[q1.front()]-a[q2.front()]>=m){ //满足条件计算值
                ans= max(ans,i-last);
            }
        } cout<<ans<<endl;
    }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值