算法笔记习题3.3

问题 A: 输出梯形


题目描述

输入一个高度h,输出一个高为h,上底边为h的梯形。

输入

一个整数h(1<=h<=1000)。

输出

h所对应的梯形。

样例输入

5

样例输出

        *****
      *******
    *********
  ***********
*************

#include <stdio.h>
char a[1000][1000];
int main()
{
	int h;
	while (scanf("%d",&h) != EOF)
	{
		for(int i=0;i<h;i++)
		{
			for(int j=0;j<3*h-2;j++)//3h-2为梯形下底 
			{	
				a[i][j]='*';
			}
		}
		for(int i=0;i<h-1;i++)
		{
			for(int j=0;j<2*h-2-2*i;j++)
			{
				a[i][j]=' ';
			}
		}
		for(int i=0;i<h;i++)
		{
			for(int j=0;j<3*h-2;j++)
			{
				printf("%c",a[i][j]);
			} 
			printf("\n");
		}
	}
	return 0;
}


问题 B: Hello World for U


题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.


输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.


输出

For each test case, print the input string in the shape of U as specified in the description.


样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor


#include <stdio.h>
#include <string.h>

int main()
{
	char str[81],a[50][50];;
	int n,col,row,count;
	while(scanf("%s",&str) != EOF)
	{
		memset(a,' ',sizeof(a));
		count=0;
		n=strlen(str) + 2;
		row=n/3;//行 
		col=n/3 + n%3;//列 
		for(int i=0;i<row;i++)
		{
			a[i][0]=str[count++];
		}
		for(int i=1;i<=col-2;i++)
		{
			a[row-1][i]=str[count++];
		}
		for(int i=row-1;i>=0;i--)
		{
			a[i][col-1]=str[count++];
		}
		for(int i=0;i<row;i++)
		{
			for(int j=0;j<col;j++)
			{
				printf("%c",a[i][j]);
			}
			if(i != row-1) printf("\n");
		}
	}
	return 0;
}



问题 C: 等腰梯形


请输入高度h,输入一个高为h,上底边长为的等腰梯形(例如h=4,图形如下)。

   ****

  ******

 ********

**********

输入

输入第一行表示样例数m,接下来m行每行一个整数h,h不超过10。

输出

对应于m个case输出要求的等腰梯形。

样例输入

1
4

样例输出

   ****
  ******
 ********
**********

#include <stdio.h>
int main()
{
	int m,h;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d",&h);
		for(int i=0;i<h;i++)
		{
			for(int j=0;j<h-1-i;j++)
			{
				printf(" ");
			}
			for(int k=0;k<h+2*i;k++)
			{
				printf("*");
			}
			printf("\n");
		}
	} 
	return 0;
}

问题 D: 沙漏图形 


题目描述

问题:输入n,输出正倒n层星号三角形。首行顶格,星号间有一空格,效果见样例 
输入样例: 

输出样例:
* * *
 * * 
  *
 * * 
* * *

#include <stdio.h>
int main()
{
	int h;
	while(scanf("%d",&h) != EOF)
	{
		for(int i=0;i<h;i++)
		{
			for(int j=0;j<i;j++)
			{
				printf(" ");
			}
			for(int j=0;j<h-i;j++)
			{
				printf("* ");
			}
			printf("\n");
		}
		for(int i=1;i<h;i++)
		{
			for(int j=0;j<h-1-i;j++)
			{
				printf(" ");	
			}
			for(int j=0;j<i+1;j++)
			{
				printf("* ");
			}
			printf("\n");
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值