hdu2119

Matrix

问题描述 :

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the ’1′ in this row or this column .

Your task is to give out the minimum times of deleting all the ’1′ in the matrix.

输入:

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

输出:

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

样例输入:

3 3 
0 0 0
1 0 1
0 1 0
0

样例输出:

2

题意很好理解,就是每次可以删除一行或者一列数,问最少几次可以把所有的1都变成0,也就是都删完。用二分图表示,行代表二分图的一部分,列代表二分图的一部分,map[i][j]==1代表连一条边,这样就转化为求最小顶点覆盖,即求二分图的最大匹配(边数最多的匹配,即把尽可能多的边与某一个顶点相关联,这样选择全部的边所需要的最少顶点就是最小顶点覆盖)。此外,二分图还有最小路径覆盖,意思是用最少的边把图中所有的顶点都遍历到(最小路径覆盖 = 顶点数 – 最大匹配)。

#include<iostream>
 #include<cstring>
 const int N=110;
 using namespace std;
 int map[N][N];
 int visited[N];
 int used[N];
 int n,m;
 
 //从定点x出发,用深度优先搜索策略寻找增广路
 int Solve(int x){
     for(int j=0;j<m;j++){
         if(map[x][j]&&!visited[j]){
             visited[j]=1;
             //如果没有匹配,或者已经匹配了,但从used[j]出发可以找到一天增广路;
             //如果前一个条件成立,则不会递归调用
             if(used[j]==-1||Solve(used[j])){
                 used[j]=x;
                 return 1;
             }
         }
     }
     return 0;
 }
 
 
 //求二部图最大匹配的匈牙利算法
 int MaxMatch(){
     int count=0;
     for(int i=0;i<n;i++){
         memset(visited,0,sizeof(visited));
         if(Solve(i))count++;
     }
     return count;
 }
 
 int main(){
     while(~scanf("%d",&n)&&n){
         scanf("%d",&m);
         for(int i=0;i<n;i++){
             for(int j=0;j<m;j++){
                 scanf("%d",&map[i][j]);
             }
         }
         memset(used,-1,sizeof(used));
         int ans=MaxMatch();
         printf("%d\n",ans);
     }
     return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值