hdu5512 - A Curious Matt (排序)水

There is a curious man called Matt. 

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
Input
The first line contains only one integer T, which indicates the number of test cases. 

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records. 

Each of the following N lines contains two integers t  i and x  i (0 ≤ t  i, x  i ≤ 10 6), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all t  i would be distinct.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places. 
Sample Input
2
3
2 2
1 1
3 4
3
0 3
1 5
2 0
Sample Output
Case #1: 2.00
Case #2: 5.00


        
  
Hint
In the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.


题意:一个人在跑步,给出其在n个位置的时刻,每两个相邻位置之间这个人速度恒定,忽略加速的时间,问这个人最大速度

数学模型:对xi升序排,更新(x[i]-x[i-1])/(t[i]-t[i-1])的最大值即可 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
//ios::sync_with_stdio(false);
typedef long long ll;
typedef long long LL;
using namespace std;
int n;
struct data
{
    double t;
    double x;
}a[10000+5];
int cmp(const data &q,const data &w)
{
    return q.t<w.t;
}
int main()
{
    int T;
    cin>>T;
    int cas = 1;
    while(T--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
            scanf("%lf%lf",&a[i].t,&a[i].x);
        sort(a,a+n,cmp);
        double ans = 0;
        for(int i=0;i<n-1;i++)
        {
            double tmp = fabs(a[i+1].x-a[i].x)/(a[i+1].t-a[i].t);
            if(ans<tmp)
                ans = tmp;
        }
        printf("Case #%d: %.2f\n",cas++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值