HDU4786 Fibonacci Tree 解题报告 【图论】【Kruskal】

该博客介绍了如何解决一个关于图论的问题,即在一个包含白色和黑色边的图中,是否存在一种方式构建一棵生成树,使得白色边的数量为斐波那契数。博主通过Kruskal算法进行求解,并提供了相应的代码实现。
摘要由CSDN通过智能技术生成

Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, … )
Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 105) and M(0 <= M <= 105).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
Sample Input
2
4 4
1 2 1
2 3 1
3 4 1
1 4 0
5 6
1 2 1
1 3 1
1 4 1
1 5 1
3 5 1
4 2 1
Sample Output
Case #1: Yes
Case #2: No
题解
这道题的题意就是说我们用白色和黑色的边搭起一颗生成树,有无办法让白色的边的边数是斐波那契数。因为我们不知道到底有几条白边,所以我们希望找到这个白边边数的上下界,枚举他的范围,再打一个表记录数据范围以内的斐波那契数,到时候对着表判定就行了。那么怎么去找这个上下界呢?我们也用Kruskal(贪心)的思路,优先选择白边或黑边(排序的时候改一改cmp)就行了。
代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e5;
int head[N+5],num;
int T;
int n,m;
bool fib[N+5];
int father[N+5];
struct edge
{
    int u,v,w,c;
    int next;
    edge(){next=-1;}
}ed[N*2+5];
void build(int u,int v,int c)
{
    ed[++num].u=u;
    ed[num].v=v;
    ed[num].c=c;
    ed[num].next=head[u];
    head[u]=num;
}
void fi()//打表打出斐波那契数 
{
    memset(fib,false,sizeof(fib));
    int i=1,j=2,k=0;
    fib[1]=fib[2]=true;
    while(k<N)
    {
        k=i+j;
        fib[k]=true;
        i=j,j=k;
    }
}
bool cmp1(edge a,edge b)
{
    return a.c<b.c;
}
bool cmp2(edge a,edge b)
{
    return a.c>b.c;
}
int getfather(int x)
{
    return (father[x]==x)?x:(father[x]=getfather(father[x]));
}
int merge(int x,int y)
{
    return ((x=getfather(x))!=(y=getfather(y)))&&(father[x]=y);
}
int kruskal1()//优先选择黑边,白边最少 
{
    int totw=0,tot=0;
    for(int i=1;i<=n;i++)
    father[i]=i;
    sort(ed+1,ed+1+num,cmp1);
    for(int i=1;i<=num;i++)
    {
        int u=getfather(ed[i].u);
        int v=getfather(ed[i].v);
        if(u!=v)
        {
            if(ed[i].c)totw++;
            merge(u,v);
            tot++;
        }
        if(tot==n-1)return totw;
    }
    return -1;
}
int kruskal2()//优先选择白边,白边最多 
{
    int totw=0,tot=0;
    for(int i=1;i<=n;i++)
    father[i]=i;
    sort(ed+1,ed+1+num,cmp2);
    for(int i=1;i<=num;i++)
    {
        int u=getfather(ed[i].u);
        int v=getfather(ed[i].v);
        if(u!=v)
        {
            if(ed[i].c)totw++;
            merge(u,v);
            tot++;
        }
        if(tot==n-1)return totw;
    }
    return -1;
}
int main()
{
    fi();
    scanf("%d",&T);
    for(int k=1;k<=T;k++)
    {
        memset(head,-1,sizeof(head));
        num=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            int u,v,c;
            scanf("%d%d%d",&u,&v,&c);
            build(u,v,c);
            build(v,u,c);
        }
        int lf=kruskal1(),rg=kruskal2();
        if(lf==-1)//lf和rg都可以 
        {
            printf("Case #%d: No\n",k);
            continue; 
        }
        int flag=0;
        for(int i=lf;i<=rg;i++)
        {
            if(fib[i])
            {
                flag=1;
                break;
            }
        }
        if(flag)printf("Case #%d: Yes\n",k);
        else printf("Case #%d: No\n",k);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值