HDU3695 Computer Virus on Planet Pandora 解题报告【字符串】【AC自动机】

Problem Description
Aliens on planet Pandora also write computer programs like us. Their programs only consist of capital letters (‘A’ to ‘Z’) which they learned from the Earth. On
planet Pandora, hackers make computer virus, so they also have anti-virus software. Of course they learned virus scanning algorithm from the Earth. Every virus has a pattern string which consists of only capital letters. If a virus’s pattern string is a substring of a program, or the pattern string is a substring of the reverse of that program, they can say the program is infected by that virus. Give you a program and a list of virus pattern strings, please write a program to figure out how many viruses the program is infected by.
Input
There are multiple test cases. The first line in the input is an integer T ( T<= 10) indicating the number of test cases.
For each test case:
The first line is a integer n( 0 < n <= 250) indicating the number of virus pattern strings.
Then n lines follows, each represents a virus pattern string. Every pattern string stands for a virus. It’s guaranteed that those n pattern strings are all different so there
are n different viruses. The length of pattern string is no more than 1,000 and a pattern string at least consists of one letter.
The last line of a test case is the program. The program may be described in a compressed format. A compressed program consists of capital letters and
“compressors”. A “compressor” is in the following format:
[qx]
q is a number( 0 < q <= 5,000,000)and x is a capital letter. It means q consecutive letter xs in the original uncompressed program. For example, [6K] means
‘KKKKKK’ in the original program. So, if a compressed program is like:
AB[2D]E[7K]G
It actually is ABDDEKKKKKKKG after decompressed to original format.
The length of the program is at least 1 and at most 5,100,000, no matter in the compressed format or after it is decompressed to original format.
Output
For each test case, print an integer K in a line meaning that the program is infected by K viruses.
Sample Input
3
2
AB
DCB
DACB
3
ABC
CDE
GHI
ABCCDEFIHG
4
ABB
ACDEE
BBB
FEEE
A[2B]CD[4E]F
Sample Output
0
3
2
Hint
In the second case in the sample input, the reverse of the program is ‘GHIFEDCCBA’, and ‘GHI’ is a substring of the reverse, so the program is infected
by virus ‘GHI’.
解题报告
显然这道题用AC自动机来解。需要注意的是,其输入有点奇怪的格式,到时候的答案我们正反两边查询一遍就好了。

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
using namespace std;
typedef long long LL;
const int CHAR_SIZE=26;
const int MAX_SIZE=2.5e5+8;
struct AC_Machine
{
    int ch[MAX_SIZE][CHAR_SIZE], danger[MAX_SIZE], fail[MAX_SIZE];
    int sz;
    inline void init()
    {
        sz=1;
        memset(ch[0],0,sizeof ch[0]);
        memset(danger,0,sizeof danger);
    }
    inline void _insert(char *s)
    {
        int n=strlen(s);
        int u=0,c;
        for(int i=0;i<n;i++)
        {
            c=s[i]-'A';
            if(!ch[u][c])
            {
                memset(ch[sz],0,sizeof ch[sz]);
                danger[sz]=0;
                ch[u][c]=sz++;
            }
            u=ch[u][c];
        }
        danger[u]++;
    }
    inline void _build()
    {
        queue<int> Q;
        fail[0] = 0;
        for(int c=0,u;c<CHAR_SIZE;c++)
        {
            u=ch[0][c];
            if(u){Q.push(u);fail[u]=0;}
        }
        int r;
        while(!Q.empty())
        {
            r=Q.front();
            Q.pop();
            for(int c=0,u;c<CHAR_SIZE;c++)
            {
                u=ch[r][c];
                if(!u){ch[r][c]=ch[fail[r]][c];continue;}
                fail[u]=ch[fail[r]][c];
                Q.push(u);
            }
        }
    }
}ac;
const int maxn=5.1e6 + 8;
char s[maxn];
int main()
{
    int T, n, len, i, v, ans, now, tmp;
    char ch;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        ac.init();
        while(n--)
        {
            scanf("%s", s);
            ac._insert(s);
        }
        ac._build();
        len=0,v=1;getchar();
        while(true)
        {
            ch=getchar();
            if(ch=='[')scanf("%d", &v);
            else if(ch==']');
            else if(isalpha(ch))
            {
                while(v--)
                {
                    s[len]=ch;
                    len++;
                }
                v=1;
            }
            else break;
        }
        s[len]='\0',ans=0,now=0;
        for(i=0;i<len;i++)
        {
            now=ac.ch[now][s[i]-'A'];
            tmp=now;
            while(tmp)
            {
                if(ac.danger[tmp]>0)
                {
                    ans+=ac.danger[tmp];
                    ac.danger[tmp]=-1;
                }
                else if(ac.danger[tmp]==-1)break;
                tmp=ac.fail[tmp];
            }
        }
        now=0;
        for(i=len-1;i>=0;i--)
        {
            now=ac.ch[now][s[i]-'A'];
            tmp=now;
            while(tmp)
            {
                if(ac.danger[tmp]>0)
                {
                    ans+=ac.danger[tmp];
                    ac.danger[tmp]=-1;
                }
                else if(ac.danger[tmp]==-1)break;
                tmp=ac.fail[tmp];
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值