POJ-1007:DNA Sorting

1007:DNA Sorting

时间限制: 
1000ms 
内存限制: 
65536kB
描述
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
输入
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
输出
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
样例输入
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
样例输出
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题目的本质是计算逆序数,然后根据逆序数,对DNA序列进行排序
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;



int main()
{
	/* recept the parameters */
	int length = 0;
	int n = 0;
	cin>>length;
	cin>>n;

	char **DNASeq = new char* [n];
	for(int i=0; i<n; ++i)
	{	
		DNASeq[i] = new char[length];
		cin>>DNASeq[i];		
	}
	

	/* calculate the number of inversions */
	int *inversions = new int [n];
	for(int i=0; i<n; ++i)
	{	
		inversions[i] = 0; /* initiate the array of inversion number */

		for(int j=0; j<length; ++j)
			for(int k=j+1; k<length; ++k)
				if( DNASeq[i][j]>DNASeq[i][k])
					inversions[i]++;
				
	}

	/*Bubble sort*/
	for(int i=0; i<n; ++i)
		for(int j=n-1; j>i; --j)
			if( inversions[j] < inversions[j-1])
			{
				int temp        = inversions[j];    /*swap*/
				inversions[j]   = inversions[j-1];
				inversions[j-1] = temp;

				char *tmp   = DNASeq[j];
				DNASeq[j]   = DNASeq[j-1];
				DNASeq[j-1] = tmp;
			}
	

	/*OUTPUT*/
	for(int i=0; i<n; ++i)
	{	cout<<DNASeq[i]<<endl;	}
	

	return 0;
}

排序部分为简洁,使用的是冒泡排序,也可将 DNA序列 和 逆序值 做成一个数据结构,然后用STL的sort排序,应该可以更加简洁。


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值