【HDU2602】Bone Collector(01背包入门级)

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

思路:01背包就是对每个物体进行放或者不放的操作。
状态转移方程: dp[j]=max(dp[j],dp[j-weight]+price[i]);

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e4+5;

struct FYJ
{
    int v;
    int w;
} fyj[maxn];

int dp[maxn];

int max( int a,int b )
{
    return a>b? a:b;
}

int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while( T-- )
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&m);
        for( int i=1 ; i<=n ; i++ ) scanf("%d",&fyj[i].v);
        for( int i=1 ; i<=n ; i++ ) scanf("%d",&fyj[i].w);
        for( int i=1 ; i<=n ; i++ )
           for( int j=m ; j>=fyj[i].w ; j-- )
           {
            dp[j] = max( dp[j] , dp[j-fyj[i].w]+fyj[i].v );
           }
           printf("%d\n",dp[m]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值