【POJ 3630】Phone List(静态字典树)

Phone List

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题目大意:你输入T表示T组样例,输入n表示n个号码。然后判断有没有号码是其他号码的前缀这种情况,如果有就输出NO没有就输出YES。如你的字典树中有了911,你就不能拨打911········这样的电话了。
这题可以字典序排序后两两之间比较一下做出来。但是这只给出静态字典树的代码。动态字典树在这种可能有10000个单词的情况下不能用否自会内存超限。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

struct Trie  {  
    int count;  
    struct Trie *branch[10];  
}Memory[100005]; 

int num = 0;  

Trie *TrieNode()  {  
    Trie *p = &Memory[num++];  
    p->count = 0;  
    for(int k = 0; k < 10; k++){  
        p->branch[k] = NULL;  
    }  
    return p;  
}  

//将字符串number插入根为root的字典树  
void MakeTrie(Trie *&root, char *number){  
    int i = 0;  
    if(root == NULL){  
        root = TrieNode();  
    }  
    Trie *p = root;  
    while(number[i]){  
        if(!p->branch[number[i] - '0']){  
            p->branch[number[i] - '0'] = TrieNode();  
        }  
        p = p->branch[number[i] - '0'];  
        p->count++;  
        i++;  
    }  
}  

//判断字符串number是否为其他某字符串的前缀  
//如果是返回true,否则返回false  
bool IsPrefix(Trie *root, char *number){  
    int i = 0;  
    if(root == NULL){  
        return true;  
    }  
        Trie *p = root;  
    while(number[i]){  
        p = p->branch[number[i] - '0'];  
        if(p->count == 1)  
            return false;  
        i++;  
    }  
    return true;  
}  

int main(){  
    bool flag = true;  
    int j, n, t;  
    Trie *root = NULL;  
    char numbers[100005][11];  
    scanf("%d", &t);  
    while(t--){  
        scanf("%d", &n);  
        root = NULL;  
        for(j = 0; j < n; j++){  
            scanf("%s", numbers[j]);  
            MakeTrie(root, numbers[j]);  
        }  

        for(j = 0; j < n; j++){  
            if(IsPrefix(root, numbers[j])){  
                flag = false;  
                break;  
            }  
        }  
        if(flag){  
            printf("YES\n");  
        }  
        else{  
            printf("NO\n");  
        }  
        flag = true;  
        num = 0;  
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值