【HDU 1075】What Are You Talking About(字典树)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i’m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i’m from mars.
i like earth!

Hint

Huge input, scanf is recommended.

题目大意:在第一个START和END之间是你来定义你的词典,首先输入解释再输入单词。在后面的START和END之间是你输入的火星文句子,将里面的出现在你定义好的字典里的单词翻译成解释,如果你的字典里没有就直接输出它。
分析:这题对于字典树的插入和寻找单词解释不是很难。你直接在插入完成后记录他这个节点可以构成单词,将翻译放进这个节点所对应的解释的字符串中。之后在寻找的过程中,你需要将可以构成单词的解释输出不能解释的就直接输出其本身。这个题目的难点在于卡输入。
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e3+5;
const int MAX = 26;

char s1[maxn];
char s2[maxn];
char s3[maxn];
char s4[maxn];

struct Trie{
    bool exit;
    Trie *next[MAX];
    char trans[20];
    Trie(){
        exit = false;
        memset(next,0,sizeof(next));
        trans[0]= '\0';
    }
};

Trie *root = new Trie();

void CreateTrie( char *str , char *T ){
    Trie *p = root;
    for( int i=0 ; i<strlen(str) ; i++ ){
        int num = str[i]-'a';
        if( p->next[num] == NULL ){
            Trie *tmp = new Trie();
            p->next[num] = tmp;
        }
        p = p->next[num];
    }
    p->exit = true;
    strcpy( p->trans, T );
}

void FindTransTrie( char *str ){
    Trie *p = root;
    for( int i=0 ; i<strlen(str) ; i++ ){
        int num = str[i]-'a';
        if( p->next[num] == NULL ){
            printf("%s",str); return;
        }
        p = p->next[num];
    }
    if(p->exit){
        printf("%s",p->trans);
        return;
    }
    else{
        printf("%s",str);
        return;
    }
}

int main(){
    int k = 0;
    scanf("%s",s1);  
    while(scanf("%s",s1) && strcmp(s1 , "END") != 0){  
        scanf("%s",s2); 
        CreateTrie(s2 , s1);  
    }  
    scanf("%s",s1);
    getchar();
    while( gets(s3) ){
        if( strcmp(s3,"END") == 0 ){
            break;
        }
        for(int i=0 ; s3[i] ; i++){
            if('a'<=s3[i] && s3[i]<='z'){
                s4[k++] = s3[i];
            }
            else{
                s4[k] = '\0';
                if( s4[0] != '\0' ){ 
                    FindTransTrie( s4 );   
                    s4[0]='\0';
                    k=0;  
                }
                printf("%c",s3[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值