Elevator


Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case. 

Sample Input

1 2
3 2 3 1
0

Sample Output

17

41

题目要求是说电梯运行的问题,计算的是共需的时间。

电梯上行时每上升一层楼需6s,每下降一层需4s,电梯每次停5s,需要注意的一点是电梯是初始层数是0,而不是习惯上的1;

多组数据,结束标志是0;

其实就是个简单的数学问题,我一开始在停留5s那有点晕,后来发现电梯只有停的时候才需要加5s,所以认真审题是很重要的!!

输入停留次数及每次停留层数,输出所需总时间。

所以接下来的问题就很简单了,代码如下:

#include<iostream>
using namespace std;
int main()
{
    int n,i;                   //n为电梯停留次数,i为计数数字
    int num[101]={0};          //num数组记录的是每次停留的楼层数
    int sum;                   //sum为所需总时间
    while(cin>>n&&n)           //多组数据输入并设结束条件
    {
        sum=0;                 //每次循环sum都要赋初值0
        for(i=1;i<=n;i++)
            cin>>num[i];
        for(i=1;i<=n;i++)      //算法
        {
            if(num[i]>num[i-1])
                sum+=(num[i]-num[i-1])*6;
            else sum+=(num[i-1]-num[i])*4;
        }
        cout<<sum+n*5<<endl;   //加上停留的时间
    }
    return 0;
}


有问题欢迎指正!大笑

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值