九度OJ 1041:Simple Sorting(简单排序) (排序)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4502

解决:1680

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8
来源:
2008年上海交通大学计算机研究生机试真题

思路:

要求排序之后输出时去掉重复数字,输出时加判断即可。


代码:

#include <stdio.h>
#include <stdlib.h>
 
int cmp(const void *a, const void *b)
{
    return *((int*)a) > *((int*)b) ? 1: -1;
}
 
int main(void)
{
    int n;
    int a[1000], b[1000];
    int i;
 
    while (scanf("%d", &n) != EOF)
    {
        for (i=0; i<n; i++)
            scanf("%d", &a[i]);
 
        qsort(a, n, sizeof(a[0]), cmp);
 
        int k = 0;
        b[0] = a[0];
        for (i=0; i<n; i++)
        {
            if (a[i] != b[k])
            {
                k++;
                b[k] = a[i];
            }
        }
 
        for (i=0; i<k; i++)
            printf("%d ", b[i]);
        printf("%d\n", b[i]);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1041
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值