九度OJ 1145:Candy Sharing Game(分享蜡烛游戏) (模拟)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:248

解决:194

题目描述:

    A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
    Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with. 

输入:

    The input may describe more than one game. For each game, the input begins with the number N of students,followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself. 

输出:

    For each game, output the number of rounds of the game followed by the amount of candy each child ends up with,both on one line. 

样例输入:
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
样例输出:
15 14
17 22
4 8
提示:

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase 

来源:
2009年北京大学计算机研究生机试真题

思路:

该游戏一定能结束。主要是模拟好整个游戏过程,判断好结束条件。


代码:

#include <stdio.h>
 
#define M 1000
 
int shouldEnd(int *a, int n)
{
    if (n < 2)
        return 1;
    for (int i=1; i<n; i++)
    {
        if (a[0] != a[i])
            return 0;
    }
    return 1;
}
 
int main(void)
{
    int n, i;
    int a[M], b[M];
    int step;
 
    while (scanf("%d", &n) != EOF && n)
    {
        for(i=0; i<n; i++)
            scanf("%d", &a[i]);
        step = 0;
        while (!shouldEnd(a, n))
        {
            //printf("step = %d\n", step);
            for (i=0; i<n; i++)
            {
                b[i] = (a[i]>>1)+(a[(n+i-1)%n]>>1);
                //printf("b[%d]=%d\n", i, b[i]);
            }
            for (i=0; i<n; i++)
            {
                a[i] = ((b[i]+1)>>1)<<1;
                //printf("a[%d]=%d\n", i, a[i]);
            }
            step ++;
        }
 
        printf("%d %d\n", step, a[0]);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1145
    User: liangrx06
    Language: C
    Result: Accepted
    Time:10 ms
    Memory:912 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值