九度OJ 1324:The Best Rank(最优排名) (排序)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:489

解决:126

题目描述:

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

输入:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

输出:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

样例输入:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
样例输出:
1 C
1 M
1 E
1 A
3 A
N/A

思路:

使用了函数指针数组,认为是比较好的地方。


代码:

#include <stdio.h>
#include <stdlib.h> 
 
#define N 2000
 
typedef struct node {
    int num;
    int score[4];
    int rank[4]; 
} Stu;
 
int cmpNum(const void *a, const void *b)
{
    return ((Stu *)a)->num - ((Stu *)b)->num;
}   
     
int cmp0(const void *a, const void *b)
{       
    return ((Stu *)b)->score[0] - ((Stu *)a)->score[0];
}       
         
int cmp1(const void *a, const void *b)
{       
    return ((Stu *)b)->score[1] - ((Stu *)a)->score[1];
}
 
int cmp2(const void *a, const void *b)
{
    return ((Stu *)b)->score[2] - ((Stu *)a)->score[2];
}   
     
int cmp3(const void *a, const void *b)
{   
    return ((Stu *)b)->score[3] - ((Stu *)a)->score[3];
}   
     
void printStu(Stu *s, int n)
{   
    int i, j;
    for (i=0; i<n; i++)
    {
        printf("%d\n", s[i].num);
        for (j=0; j<4; j++)
            printf("%3d ", s[i].score[j]);
        printf("\n");
        for (j=0; j<4; j++)
            printf("%3d ", s[i].rank[j]);
        printf("\n");
    }
}
 
int main(void)
{
    int n, m, i, j;
    Stu s[N];
    int check;
 
    typedef int (*CMP)(const void *, const void *);
    CMP cmp[4];
    cmp[0] = cmp0;
    cmp[1] = cmp1;
    cmp[2] = cmp2;
    cmp[3] = cmp3;
 
    while (scanf("%d%d", &n, &m) != EOF)
    {
        for(i=0; i<n; i++)
        {
            scanf("%d%d%d%d", &s[i].num, &s[i].score[1], &s[i].score[2], &s[i].score[3]
);
            s[i].score[0] = (s[i].score[1] + s[i].score[2] + s[i].score[3])/3;
        }
 
        for(j=0; j<4; j++)
        {
            qsort(s, n, sizeof(s[0]), cmp[j]);
            for (i=0; i<n; i++)
            {
                int r = i-1;
                while (r >= 0 && s[r].score[j] == s[i].score[j])
                    r --;
                r += 2;
                s[i].rank[j] = r;
            }
        }   
         
        qsort(s, n, sizeof(s[0]), cmpNum);
        //printStu(s, n);
        for (i=0; i<m; i++)
        {
            Stu current;
            scanf("%d", &check);
            current.num = check;
            Stu *p = (Stu *)bsearch(¤t, s, n, sizeof(s[0]), cmpNum);
            if (p == NULL)
                printf("N/A\n");
            else
            {
                int bestMethod = 0;
                for (j=1; j<4; j++)
                {
                    if (p->rank[j] < p->rank[bestMethod])
                        bestMethod = j;
                }
                char tmp[5] = "ACME";
                printf("%d %c\n", p->rank[bestMethod], tmp[bestMethod]);
            }
        }
    }   
             
    return 0;
} 
/**************************************************************
    Problem: 1324
    User: liangrx06
    Language: C
    Result: Accepted
    Time:20 ms
    Memory:916 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
森林防火应急联动指挥系统是一个集成了北斗定位/GPS、GIS、RS遥感、无线网络通讯、4G网络等技术的现代化智能系统,旨在提高森林火灾的预防和扑救效率。该系统通过实时监控、地图服务、历史数据管理、调度语音等功能,实现了现场指挥调度、语音呼叫通讯、远程监控、现场直播、救火人员生命检测等工作的网络化、智能化、可视化。它能够在火灾发生后迅速组网,确保现场与指挥中心的通信畅通,同时,系统支持快速部署,适应各种极端环境,保障信息的实时传输和历史数据的安全存储。 系统的设计遵循先进性、实用性、标准性、开放性、安全性、可靠性和扩展性原则,确保了技术的领先地位和未来的发展空间。系统架构包括应急终端、无线专网、应用联动应用和服务组件,以及安全审计模块,以确保用户合法性和数据安全性。部署方案灵活,能够根据现场需求快速搭建应急指挥平台,支持高并发视频直播和大容量数据存储。 智能终端设备具备三防等级,能够在恶劣环境下稳定工作,支持北斗+GPS双模定位,提供精确的位置信息。设备搭载的操作系统和处理器能够处理复杂的任务,如高清视频拍摄和数据传输。此外,设备还配备了多种传感器和接口,以适应不同的使用场景。 自适应无线网络是系统的关键组成部分,它基于认知无线电技术,能够根据环境变化动态调整通讯参数,优化通讯效果。网络支持点对点和点对多点的组网模式,具有低功耗、长距离覆盖、强抗干扰能力等特点,易于部署和维护。 系统的售后服务保障包括安装实施服务、系统维护服务、系统完善服务、培训服务等,确保用户能够高效使用系统。提供7*24小时的实时故障响应,以及定期的系统优化和维护,确保系统的稳定运行。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值