题目1481:Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入:

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero and less than 10000.

输出:

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

样例输入:
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
样例输出:
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题意:判断所给的数据能否组成一棵树

思路:并查集,用vex记录顶点数,edge记录边数,root记录树根数,若vex>1且vex-edge=1和root=1,能成树。  

要注意几种特殊情况:

0 0 空树是一棵树

1 1 0 0不是树,不能自己指向自己

1 2 1 2 0 0 不是树,重复不行

1 2 2 3 3 4 4 5 5 1 0 0 不是树,一个节点指向自己父亲或祖先都是错误的,即5->1错

1 2 2 1 0 0也是错误的

P.s:控制数据结束的条件是x,y<0,不是x==-1&&y==-1,如果超时了,应该就是这个错误。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int a[10001];

int find(int x) //找祖先
{
	while(a[x] != x)
		x = a[x];
	return x;
}

void merge(int x,int y)//合并
{
	int t = find(x);
	int h = find(y);
	a[h]=t;
}

int  main()
{
	int n = 0,m = 0,s = 0,b,c,k = 0;
	memset(a,0,sizeof(a));
	while(cin >> b >> c)
	{
		if(b < 0) 
			break;
		else if(n == 0 && m == 0 && b == 0 && c == 0)
		{
			printf("Case %d is a tree.\n",++k);
			continue;
		}
		else  if(b == 0 && c == 0)
		{
			k++;
			for(int i = 1; i < 10001; i++)
			{
				if(a[i])
					m++;
				if(a[i]==i)
					s++;
			}
			if(s==1 && n==m-1)
				printf("Case %d is a tree.\n",k);
			else
				printf("Case %d is not a tree.\n",k);
			n=0,m=0,s=0;
			memset(a,0,sizeof(a));
		}
		else
		{
			if(!a[b])
				a[b]=b;
			if(!a[c])
				a[c]=c;
			merge(b,c);
			n++;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值