题目1005:Graduate Admission

题目描述:

    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <algorithm>
using namespace std;

struct stu{
	int id,ge,gi;
	int choice[5];
};
struct sch{
	int quota;
	int front,rear;
	stu st[100];
};
bool cmp(stu a,stu b){
	if(a.ge + a.gi != b.ge + b.gi)
		return a.ge + a.gi > b.ge + b.gi; 
	else
		return a.ge > b.ge;
}

bool cmpbyno(stu a,stu b){
	return a.id < b.id;
}

stu s[100];
sch scl[100];
int main()
{
	int n,m,k;
	while(cin >> n >> m >> k){
		for(int i = 0;i < m;i++){
			scanf("%d",&scl[i].quota);
			scl[i].front = scl[i].rear = 0;
		}
		for(int i = 0;i < n;i++){
			scanf("%d %d",&s[i].ge,&s[i].gi);
			s[i].id = i;
			for(int j = 0;j < k;j++)
				scanf("%d",&s[i].choice[j]);
		}
		sort(s,s + n,cmp);

		for(int i = 0;i < n;i++)
		{
			for(int j = 0;j < k;j++){
				if(scl[s[i].choice[j]].quota > 0 || s[i].ge == scl[s[i].choice[j]].st[scl[s[i].choice[j]].rear - 1].ge && s[i].gi == scl[s[i].choice[j]].st[scl[s[i].choice[j]].rear - 1].gi){
					scl[s[i].choice[j]].quota--;
					scl[s[i].choice[j]].st[scl[s[i].choice[j]].rear++] = s[i];
					break;
				}
			}
		}

		for(int i = 0; i < m;i++){
			if(scl[i].front == scl[i].rear)
				cout << endl;
			else{
				sort(scl[i].st,scl[i].st + scl[i].rear,cmpbyno);
				cout << scl[i].st[scl[i].front++].id;
				while(scl[i].rear != scl[i].front){
					cout << " " << scl[i].st[scl[i].front++].id; 
				}
				cout << endl;
			}
		}
	}
	return 1;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值