-
题目描述:
-
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
-
输入:
-
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
-
输出:
-
对每个测试用例,在1行里输出最小的公路总长度。
-
样例输入:
-
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
-
样例输出:
-
3 5
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
int f[1002],u[5000],v[5000],r[5000],w[5000];
int find(int a){
return a == f[a] ? a : f[a] = find(f[a]);
}
int cmp(const int i,const int j){
return w[i] < w[j];
}
int main()
{
int n,m,a,b;
while(cin >> n && n){
int ans = 0;
int m = n * (n - 1) / 2;
for(int i = 1;i <= n;i++)
f[i] = i;
for(int i = 1;i <= m;i++)
r[i] = i;
for(int i = 1;i <= m;i++)
scanf("%d %d %d",&u[i],&v[i],&w[i]);
sort(r,r + m,cmp);
for(int i = 1;i <= m;i++){
int e = r[i];
int x = find(u[e]);
int y = find(v[e]);
if(x != y){
ans += w[e];
f[x] = y;
}
}
cout << ans << endl;
}
return 1;
}
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
struct edge{
int u,v,w;
};
int f[102];
edge e[5000];
int find(int a){
return a == f[a] ? a : f[a] = find(f[a]);
}
int cmp(const edge a,const edge b){
return a.w < b.w;
}
int main()
{
int n,m;
while(cin >> n && n){
int ans = 0;
m = n * (n - 1) / 2;
for(int i = 1;i <= n;i++)
f[i] = i;
for(int i = 1;i <= m;i++)
scanf("%d %d %d",&e[i].u,&e[i].v,&e[i].w);
sort(e,e + m + 1,cmp);
for(int i = 1;i <= m;i++){
int x = find(e[i].u);
int y = find(e[i].v);
if(x != y){
ans += e[i].w;
f[x] = y;
}
}
cout << ans << endl;
}
return 1;
}