the mixed letters

Description

Mike is very upset that many people on the Internet usually mix uppercase and lowercase letters in one word. That's why he decided to invent an extension for his favorite browser that would change the letters' case in every word so that it either only consisted of lowercase letters or only consisted of uppercase ones. And he wants to change as few letters as possible in the word.
For example, the word "HoUse" must be changed to "house", and the word "ViP", to "VIP".
If a word contains an equal number of uppercase and lowercase letters, you should replace all the letters with lowercase ones. For example, "maTRIx" should be changed to "matrix".
You task is to use the given method to change the given word.

Input

The first line contains a single integer n (n<=30), indicating the number of test cases.
Then following n lines, each line contains a word s, it consists of uppercase and lowercase
Latin letters and its length is between 1 and 100, inclusive.

Output

Print the word s after change. If the given word s has strictly more uppercase letters, make the word written in the uppercase register, otherwise, in the lowercase one.

Sample Input

3

HoUse

ViP

maTRIx

Sample Output

house

VIP

matrix

#include<iostream>
#include<string.h>
#include<cstdio>
using namespace std;
string toLp(string a)
{
    for(int i=0;i<a.size();i++)
    {
        if(a[i]>='A'&&a[i]<='Z')
            a[i]+=32;
    }
    return a;
}
string toUp(string a)
{
    for(int i=0;i<a.size();i++)
    {
        if(a[i]>='a'&&a[i]<='z')
            a[i]-=32;
    }
    return a;
}
string count(string a)
{
    int len=a.size(),d=0,x=0;
    for(int i=0;i<len;i++)
    {
        if(a[i]>='A'&&a[i]<='Z')
        {
            d++;
        }
        if(a[i]>='a'&&a[i]<='z')
        {
            x++;
        }
    }
    if(x!=d)
    {
        if(x>d)
            a=toLp(a);
        if(x<d)
            a=toUp(a);
    }
    else
    {
		a=toLp(a);
    }
    return a;
}
int main()
{
    int n;
    string word[100];
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>word[i];
    }
    for(int j=0;j<n-1;j++)
        cout<<count(word[j])<<endl;
    cout<<count(word[n-1]);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值