poj 2955 区间dp 2018-3-11

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10355 Accepted: 5508

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
# include <cstdio>
# include <cstdlib>
# include <cmath>
# include <cstring>
# include <string>
# include <iostream>
# include <iomanip>
# include <algorithm>
# include <list>
# include <stack>
# include <vector>
# include <queue>
# include <map>
using namespace std;
const int INF = 0x3f3f3f3f;

char s[205];
int dp[205][205];


int main()
{
	while (scanf("%s", s) != EOF && strcmp(s, "end") != 0)
	{
		int length = strlen(s);
		memset(dp, 0, sizeof(dp));
		//memset(s, 0, sizeof(s));
		for (int i = 0; i < length; i++)dp[i][i] = 1;
		for (int d = 1; d < length; d++) {//遍历区间长度
			for (int start = 0; start < length - d; start++) {//遍历区间开头
				int end = start + d;//定义区间结尾
				dp[start][end] = INF;//因为这是唯一一次计算数组当中的这一元素,所以先初始化,之后这一元素只会被调用,不会被重新计算
				if ((s[start] == '('&&s[end] == ')') || (s[start] == '['&&s[end] == ']'))dp[start][end] = dp[start + 1][end - 1];//先判断两头是否匹配,因为接下来的操作是更小的区间操作,执行不了这一操作
				for (int k = start; k < end; k++) {//遍历这个区间的分段点
					dp[start][end] = min(dp[start][end], dp[start][k] + dp[k + 1][end]);
				}
			}
		}
		cout << length - dp[0][length - 1] << endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值