POJ1579

[url]http://poj.org/problem?id=1579[/url]
Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11121 Accepted: 5815

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.
Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

从题意很容易写出代码,但是超时,想了想,用记忆性搜索可以很好的解决此题


#include <stdio.h>
#include <math.h>
#include <string.h>

int dp[21][21][21];

int w(int a, int b, int c)
{
if(a <= 0 || b <= 0 || c <= 0)
{
return 1;
}else if(a > 20 || b > 20 || c > 20)
{
return 1048576;
}else if(a <= b && b <= c)
{
if(dp[a][b][c] == -1)
dp[a][b][c] = (int)pow(2, a);
return dp[a][b][c];
}else
{
if(a-1 >= 0&&dp[a-1][b][c] == -1)
dp[a - 1][b][c] = w(a-1, b, c);
if(a - 1 >= 0 && b - 1 >= 0 &&dp[a-1][b - 1][c] == -1)
dp[a- 1][b - 1][c] = w(a-1, b- 1, c);
if(a- 1 >= 0 && c - 1 >= 0 && dp[a - 1][b][c - 1] == -1)
dp[a- 1][b][c - 1] = w(a - 1, b, c - 1);
if(a - 1 >= 0 && b - 1 >= 0 && c - 1 >= 0)
dp[a- 1][b - 1][c - 1] = w(a - 1, b - 1, c - 1);
return dp[a - 1][b][c] + dp[a- 1][b - 1][c] + dp[a- 1][b][c - 1] - dp[a- 1][b - 1][c - 1];
}
}

//此题有如下规则:
//1.当a b c中有任意一个数大于20 则返回1048576
//2.如果 a<=b<=c 则返回 pow(2, a)
//3.其他的数据可以用记忆性搜索来提高时间
int main()
{
int a, b, c;
memset(dp, -1, sizeof(dp));
while(scanf("%d%d%d", &a, &b, &c) == 3)
{
if(a == -1 && b == -1&& c== -1)
break;
printf("w(%d, %d, %d) = %d\n", a, b, c, w(a, b, c));
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值