HDU1003

Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52982 Accepted Submission(s): 11890


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


Author
Ignatius.L


#include <stdio.h>

#define MAX 100005

int nNum[MAX];
int start, end;

//算法思路:用sum和max来记录临时最大和最终最大,而start end ts te 分别用来记录起点 终点 临时起始点 终点
int cal(int len)
{
int max, i, sum, ts, te;
sum = max = -9999; //让max和sum开始置于无限小
for(i = 0; i < len; i++)
{
if(sum < 0)
{
if(nNum[i] > sum)
{
sum = nNum[i];
ts = te = i;
if(max < sum)
{
max= sum;
start = ts;
end = te;
}
}
}else
{
sum += nNum[i];
te = i;
if(sum > max)
{
max = sum;
start = ts;
end = te;
}
}
}
return max;
}
int main()
{
int t, i, n, j;
// freopen("input.in", "r", stdin);
scanf("%d", &t);
for(i = 1; i <= t; i++)
{
scanf("%d", &n);
for(j = 0; j < n; j++)
scanf("%d", &nNum[j]);
int max = cal(n);
printf("Case %d:\n", i);
printf("%d %d %d\n", max, start + 1, end + 1);
if(i != t)
printf("\n");
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值