To the moon——区间更新主席树

Background
To The Moon is a independent game released in November 2011, it is a role-playing adventure game powered by RPG Maker.
The premise of To The Moon is based around a technology that allows us to permanently reconstruct the memory on dying man. In this problem, we’ll give you a chance, to implement the logic behind the scene.

You‘ve been given N integers A[1], A[2],…, A[N]. On these integers, you need to implement the following operations:
1. C l r d: Adding a constant d for every {Ai | l <= i <= r}, and increase the time stamp by 1, this is the only operation that will cause the time stamp increase.
2. Q l r: Querying the current sum of {Ai | l <= i <= r}.
3. H l r t: Querying a history sum of {Ai | l <= i <= r} in time t.
4. B t: Back to time t. And once you decide return to a past, you can never be access to a forward edition anymore.
.. N, M ≤ 105, |A[i]| ≤ 109, 1 ≤ l ≤ r ≤ N, |d| ≤ 104 .. the system start from time 0, and the first modification is in time 1, t ≥ 0, and won’t introduce you to a future state.

Input
n m
A1 A2 … An
… (here following the m operations. )

Output
… (for each query, simply print the result. )

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

2 4
0 0
C 1 1 1
C 2 2 -1
Q 1 2
H 1 2 1

Sample Output
4
55
9
15

0
1

区间更新的话不能pushdown,否则会多很多无用节点,极端情况就是n个线段树的内存,会爆,所以要用一个flag记录,在query的
时候加上去就好了

#include<bits/stdc++.h>
using namespace std;
#define maxn 100005
#define ll long long
int ls[maxn*25],rs[maxn*25],rt[maxn];
int n,m,tot;
ll sum[maxn*25],flag[maxn*25],a[maxn];
void build(int l,int r,int &root)
{
    root=++tot;
    flag[root]=0;
    if(l==r)
    {
        sum[root]=a[l];
        return ;
    }
    int mid=l+r>>1;
    build(l,mid,ls[root]);
    build(mid+1,r,rs[root]);
    sum[root]=sum[ls[root]]+sum[rs[root]];
}
void update(int l,int r,int &root,int last,int ql,int qr,int val)
{
    root=++tot;
    ls[root]=ls[last];
    rs[root]=rs[last];
    sum[root]=sum[last]+(ll)(min(qr,r)-max(ql,l)+1)*val;
    flag[root]=flag[last];
    if(ql<=l&&qr>=r)
    {
        flag[root]+=val;
        return ;
    }
    int mid=l+r>>1;
    if(mid>=ql)
        update(l,mid,ls[root],ls[last],ql,qr,val);
    if(mid<qr)
        update(mid+1,r,rs[root],rs[last],ql,qr,val);
}
ll query(int l,int r,int root,int ql,int qr)
{
    if(l>=ql&&r<=qr)
        return sum[root];
    ll ans;
    int mid=l+r>>1;
    ans=(ll)flag[root]*(min(qr,r)-max(ql,l)+1);
    if(mid>=ql)
        ans=ans+query(l,mid,ls[root],ql,qr);
    if(mid<qr)
        ans=ans+query(mid+1,r,rs[root],ql,qr);
    return ans;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        tot=0;
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        build(1,n,rt[0]);
        char s[2];
        int x,y,val;
        int now=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%s",s);
            if(s[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(1,n,rt[now],x,y));
            }
            else if(s[0]=='C')
            {
                scanf("%d%d%d",&x,&y,&val);
                now++;
                update(1,n,rt[now],rt[now-1],x,y,val);
            }
            else if(s[0]=='H')
            {
                scanf("%d%d%d",&x,&y,&val);
                printf("%lld\n",query(1,n,rt[val],x,y));
            }
            else if(s[0]=='B')
            {
                scanf("%d",&now);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值