ACM-ICPC 2018 徐州赛区网络预赛 H. Ryuji doesn't want to study—— 树状数组

Ryuji is not a good student, and he doesn’t want to study. But there are n books he should learn, each book has its knowledge a[i]a[i].

Unfortunately, the longer he learns, the fewer he gets.

That means, if he reads books from ll to rr, he will get a[l] \times L + a[l+1] \times (L-1) + \cdots + a[r-1] \times 2 + a[r]a[l]×L+a[l+1]×(L−1)+⋯+a[r−1]×2+a[r] (LL is the length of [ ll, rr ] that equals to r - l + 1r−l+1).

Now Ryuji has qq questions, you should answer him:

  1. If the question type is 11, you should answer how much knowledge he will get after he reads books [ ll, rr ].

  2. If the question type is 22, Ryuji will change the ith book’s knowledge to a new value.

Input
First line contains two integers nn and qq (nn, q \le 100000q≤100000).

The next line contains n integers represent a[i]( a[i] \le 1e9)ai .

Then in next qq line each line contains three integers aa, bb, cc, if a = 1a=1, it means question type is 11, and bb, cc represents [ ll , rr ]. if a = 2a=2 , it means question type is 22 , and bb, cc means Ryuji changes the bth book’ knowledge to cc

Output
For each question, output one line with one integer represent the answer.

样例输入 复制
5 3
1 2 3 4 5
1 1 3
2 5 0
1 4 5
样例输出 复制
10
8
转化一下问题,可以把它当成一个倒三角:
这里写图片描述
那么红色的面积就相当于黑色的r-(l-1)的面积减去绿色的面积,就好了。
树状数组线段树什么的都可以做。

#include<bits/stdc++.h>
using namespace std;
#define LL long long
const int N=100009;

LL zhi[N],shu[N];
LL ans;
LL S[N];
LL lowbit(LL i){
    return i&(-i);
}
int n,q;

void up(int a,LL m){//A[a]+=m
    int tmp=a;
    LL val=m-S[a];
    while(a<=n){
        zhi[a]+=val;
        a+=lowbit(a);
    }
    val=((LL)(n-tmp+1))*(m-S[tmp]);
    S[tmp]=m;
    while(tmp<=n){
        shu[tmp]+=val;
        tmp+=lowbit(tmp);
    }
}

LL qzhi(int p){
    LL sum=0;
    while(p>0){
        sum+=zhi[p];
        p-=p&(-p);
    }
    return sum;
}

LL qshu(int p){
    LL sum=0;
    while(p>0){
        sum+=shu[p];
        p-=p&(-p);
    }
    return sum;
}

int main(){
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++){
        LL tmp;scanf("%lld",&tmp);
        up(i,tmp);
    }
    while(q--){
        int f;
        scanf("%d",&f);
        if(f==1){
            int l,r;scanf("%d%d",&l,&r);
            LL ans=0;
            ans=qshu(r)-qshu(l-1)-(LL)(n-r)*(qzhi(r)-qzhi(l-1));
            printf("%lld\n",ans);
        }
        else{
                int p;
            LL v;scanf("%d%lld",&p,&v);
            up(p,v);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值