1014. 福尔摩斯的约会 (20)
时间限制
100 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
大侦探福尔摩斯接到一张奇怪的字条:“我们约会吧!3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm”。大侦探很快就明白了,字条上奇怪的乱码实际上就是约会的时间“星期四 14:04”,因为前面两字符串中第1对相同的大写英文字母(大小写有区分)是第4个字母'D',代表星期四;第2对相同的字符是'E',那是第5个英文字母,代表一天里的第14个钟头(于是一天的0点到23点由数字0到9、以及大写字母A到N表示);后面两字符串第1对相同的英文字母's'出现在第4个位置(从0开始计数)上,代表第4分钟。现给定两对字符串,请帮助福尔摩斯解码得到约会的时间。
输入格式:
输入在4行中分别给出4个非空、不包含空格、且长度不超过60的字符串。
输出格式:
在一行中输出约会的时间,格式为“DAY HH:MM”,其中“DAY”是某星期的3字符缩写,即MON表示星期一,TUE表示星期二,WED表示星期三,THU表示星期四,FRI表示星期五,SAT表示星期六,SUN表示星期日。题目输入保证每个测试存在唯一解。
输入样例:3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm输出样例:
THU 14:04
代码:
#include<iostream>
#include<string>
using namespace std;
int min(int x, int y){
if (x > y)
return y;
else return x;
}
bool isup(char ch){
if (ch <= 'G'&&ch >= 'A')
return 1;
else return 0;
}
bool isletter(char ch){
if ((ch <= 'Z'&&ch >= 'A') || (ch <= 'z'&&ch >= 'a'))
return 1;
else return 0;
}
int time(char ch){
if (ch >= '0'&&ch <= '9')
return(ch - '0');
else if (ch >= 'A'&&ch <= 'N')
return(ch - 'A' + 10);
}
int main(){
string s1, s2, s3, s4;
cin >> s1 >> s2 >> s3 >> s4;
int temp[3];
int count = 0;
for (int i = 0; i < min(s1.size(), s2.size()); i++){
if ((s1[i] == s2[i]) && isup(s1[i]) && isup(s2[i])){
count = i;
temp[0] = s1[i] - 'A' + 1;
break;
}
}
for (int i = count + 1; i < min(s1.size(), s2.size()); i++){
if ((s1[i] == s2[i]) && ((s1[i] <= 'N'&&s1[i] >= 'A') || s1[i] <= '9'&&s1[i] >= '0')){
temp[1] = time(s1[i]);
break;
}
}
int loc = 0;
for (int i = 0; i < min(s3.size(), s4.size()); i++){
if ((s3[i] == s4[i]) && isletter(s3[i]) && isletter(s4[i]))
temp[2] = loc;
else loc++;
}
if (temp[0] == 1)
cout << "MON" << " ";
else if (temp[0] == 2)
cout << "TUE" << " ";
else if (temp[0] == 3)
cout << "WED" << " ";
else if (temp[0] == 4)
cout << "THU" << " ";
else if (temp[0] == 5)
cout << "FRI" << " ";
else if (temp[0] == 6)
cout << "SAT" << " ";
else cout << "SUN" << " ";
if (temp[1] / 10)
cout << temp[1] << ":";
else cout << '0' << temp[1] << ":";
if (temp[2] / 10)
cout << temp[2] << endl;
else cout << '0' << temp[2] << endl;
system("pause");
return 0;
}
本题主要的问题是 判断的条件。。。提交了好几次才发现问题。。。
day:看前两个字符串第一个相等的大写字母,并且一定要是A~G
hour:同样看前两个字符串第二个相等的大写字母,并且一定在0~9、A~N
min:看后两个字符寻找第一个相等字符的位置,一定要是字母