PAT乙级1043

1043. 输出PATest(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
#include <stdio.h>
#include <iostream>
#include <cstdlib>
#include <cmath>
#include <cctype>
#include <string>
#include <cstring>
#include <algorithm>
#include <ctime>
#include<vector>
#include<map>

using namespace std;

bool isnull(int *num){
	for (int i = 0; i < 6; i++)
		if (num[i])
			return 0;
	return 1;
}

int main(){
	string s;
	string example = "PATest";
	int min = 0;
	int num[6] = { 0 };
	cin >> s;
	for (int i = 0; i < s.size(); i++){
		if (example.find(s[i]) != string::npos)
			num[example.find(s[i])]++;
	}
	min = num[0];
	for (int i = 1; i < 6; i++)
		if (min>num[i])
			min = num[1];
	for (int i = 0; i < min; i++)
		cout << "PATest";
	for (int i = 0; i < 6; i++)
		num[i] -= min;
	while (!isnull(num)){
		for (int i = 0; i < 6; i++){
			if (num[i]){
				cout << example[i];
				num[i]--;
			}
		}
	}
	cout << endl;
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值