1004. Bracket Matching

1004. Bracket Matching
 
 
Total:494 Accepted:92
 
     
     
 
Time Limit: 1sec    Memory Limit:256MB
Description

检查输入字符串中的括号是否匹配。括号包括:{, }, (, ), [, ].
 

Input

第一行是一整数,即测试样例个数n.
以下n行,每一行是一个长度不超过100个字符的字符串。
 

Output

第一行是一整数,即测试样例个数n.
以下n行,每一行是一个长度不超过100的字符串。
 

Sample Input
 Copy sample input to clipboard
3
a
2-[(1+2)*2]
(a+b])
Sample Output
Yes
Yes
No



#include<iostream>
#include<string>
#include<stack>

using namespace std;

int main() {
    int n;
    cin >> n;
    while (n--) {
        string str;
        stack<char> temp;
        cin >> str;
        int size = str.length();
        for (int i = 0; i < size; i++) {
            if (str[i] == '(' || str[i] == '{' || str[i] == '[') {
                temp.push(str[i]);
            } else if (str[i] == ')') {
                if (temp.empty()) {
                    temp.push(str[i]);
                } else {
                    if (temp.top() == '(') {
                        temp.pop();
                    } else {
                        temp.push(str[i]);
                    }
                }
            } else if (str[i] == '}') {
                if (temp.empty()) {
                    temp.push(str[i]);
                } else {
                    if (temp.top() == '{') {
                        temp.pop();
                    } else {
                        temp.push(str[i]);
                    }
                }
            } else if (str[i] == ']') {
                if (temp.empty()) {
                    temp.push(str[i]);
                } else {
                    if (temp.top() == '[') {
                        temp.pop();
                    } else {
                        temp.push(str[i]);
                    }
                }
            }
        }
        if (temp.empty()) {
            cout << "Yes" << endl;
        } else {
            cout << "No" << endl;
        }
    }
}



算法:利用栈,遍历一个string,遇到左括号就push,遇到右括号如果栈为空就push,不为空,然后栈顶为相匹配的右括号就pop,否则就push
如果最后栈为空,则括号匹配,否则括号不匹配。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值