Subsequence POJ - 3061

题目:

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:

给你一个数字T,代表有T组测试数据;

给你两个数字n和s,代表有n个数字,s是要求求出来的数组的长度;

下面的是n个数字;

思路:

数据的范围很大,所以直接暴力行不通;

直接用尺取法和前缀和;

 int t=lower_bound(sum+k,sum+n,sum[k]+s)-sum;

lower_bound(sum+a,sum+b,c) - sum函数的用法:

 查找有序区间中第一个大于或等于某给定值的元素的位置;

sum代表的是你要使用的数组;

数据范围是sum[ a ]~~sum[ b ];

lower_bound(sum+a,sum+b,c)  :求出的结果是第一个大于等于数值 c 的数组的下标;

lower_bound(sum+a,sum+b,c) - sum :减去数字开始的位置,那么结果就是你求出的数值在数组中的位置;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=100100;

int t,n,s,a;
int sum[N];

void solve()
{
    if(sum[n]<s)//整体的和还比要求的结果小,就不会有结果;
    {
        printf("0\n");
    }
    else
    {
        int res=n;
        for(int k=0; sum[k]+s<=sum[n]; k++)
        {
            int t=lower_bound(sum+k,sum+n,sum[k]+s)-sum;
            //查找有序区间中第一个大于或等于某给定值的元素的位置;
            res=min(res,t-k);
        }
        printf("%d\n",res);
    }
    return ;
}

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&s);
        memset(sum,0,sizeof sum);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a);
            sum[i+1]=sum[i]+a;//前缀和;
        }
        solve();
    }
    return 0;
}
wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值