Backward Digit Sums POJ - 3187 (枚举+全排列)

题目:

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题意:

要玩一个游戏,把三角形的斜角上的值相加,就等于下面的一个位置的值,给你两个数字N,M, 让你判断出来,1--N中,数字怎样排序才能使最终的和为M,输出最小的字典序;

思路:

因为数据范围很小,所以可以直接枚举所有的可能进行判断,关于枚举的过程,数据可以由全排列函数来进行操作;

全排列函数的使用:

do
{
    //你要进行的操作;
}                   //数组名  数组名 + 数组长度
while(next_permutation(a     ,  a    +    n ));//全排列函数;

把上面的三角形进行转换,你就可以得到求解的规律:  a[i+1][j]=a[i][j]+a[i][j+1];

3    1    2    4
4    3    6
7    9
16

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=120;

int a[N][N];
int n,m;

void print()//输出;
{
    printf("%d",a[0][0]);//注意格式;
    for(int i=1; i<n; i++)
        printf(" %d",a[0][i]);
    printf("\n");
    return ;
}

void solve()
{
    do
    {
        int s=n;
        for(int i=0; i<n-1; i++)
        {
            for(int j=0; j<n-1; j++)
            {
                a[i+1][j]=a[i][j]+a[i][j+1];
            }
        }
        if(a[n-1][0]==m)
        {
            print();
            return;
        }
    }
    while(next_permutation(a[0],a[0]+n));//全排列函数;
    return ;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<n; i++)
        {
            a[0][i]=i+1;
        }
        solve();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值