Face The Right Way POJ - 3276

题目:

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2.. N+1: Line i+1 contains a single character, F or B, indicating whether cowi is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

题意:

给你一个数字N,代表有N头牛,下面的有N个字母,如果字母是B,代表牛面向后;如果字母是F,代表牛面向前;

你可以对牛进行反转,每一次反转是对于一个区间的所有的牛进行反转,如果面向前进行反转后就是面向后;如果是面向后,经过翻转后就是面向前;

让你求出来经过最小次反转可以使所有的牛都是面向前;

输出反转区间的长度  K  和最小的反转次数  M  ;

思路:

我们看到这道题就可以知道,我们要对于反转区间的长度  K  进行枚举, 每一次对N头牛进行考虑,都是先考虑第一位面向后的牛,一定要把这头牛进行反转,然后再对于区间[  i  , i + K - 1  ]的牛进行反转;那么这个算法的时间复杂度是O(N^3);

对于上面算法我们可以进行优化,优化的部分就是区间反转的部分

用一个数组来记录区间[  i  , i + K - 1  ]的反转次数,因为牛如果进行了2次反转相当于没有进行反转;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=5010;

int n;
char s;
int dir[N];///B :1;   F : 0;
int f[N];///区间[ i,i+K-1 ]是否进行反转;反转了为1,否则为0;

int calc(int K)///判断每一反转的区间长度是K;
{
    memset(f,0,sizeof f);
    int res=0;///反转的次数;
    int sum=0;///f的和;
    for(int i=0; i+K<=n; i++)///计算区间[i,i+K-1];
    {
        ///sum代表这个区间反转的总次数;
        if((dir[i]+sum)%2!=0)///牛面朝后;
        {
            res++;///反转次数+1;
            f[i]=1;///代表区间[ i,i+K-1 ]进行了反转;
        }
        sum+=f[i];///反转次数求和;
        if(i-K+1>=0)///
            sum-=f[i-K+1];
    }
    ///检查剩下的牛是否还有面朝后的牛,如果有,那么就是无解;
    ///因为每一次的反转都是一个区间进行反转;
    for(int i=n-K+1; i<n; i++)
    {
        if((dir[i]+sum)%2!=0)
            return -1;
        if(i-K+1>=0)
            sum-=f[i-K+1];
    }
    return res;
}

void solve()
{
    int K=1,M=n;
    for(int k=1; k<=n; k++)///对于一次反转的区间长度进行枚举;
    {
        int m=calc(k);
        if(m>=0&&M>m)///有解,找最小值;
        {
            M=m;
            K=k;
        }
    }
    printf("%d %d\n",K,M);
    return ;
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            getchar();
            scanf("%c",&s);
            if(s=='B')
                dir[i]=1;
            else
                dir[i]=0;
        }
        solve();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值