Sum Problem --JAVA

题目:

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge). 

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n. 

Input

The input will consist of a series of integers n, one integer per line. 

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer. 

Sample Input

1
100

Sample Output

1

5050

题意:

给你一个数字n,求出1到n的和,

注意格式,每个结果后面有一个空行。

代码如下:

JAVA:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner input=new Scanner(System.in);
	int n,a,s;
	while(input.hasNext()) {
		n=input.nextInt();
		s=0;
		for(int i=1;i<=n;i++) {
			s+=i;
		}
		System.out.println(s);
		System.out.println();
	}
}
}

C++:

#include<stdio.h>
int main()
{
    int i,n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(i=0;i<=n;i++)
        {
            sum=sum+i;
        }
        printf("%d\n",sum);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值