Red and Black POJ - 1979

题目:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意:

给你连个数字n和m,代表图有m行n列,(图的规格是m*n),然后就是一个地图,“.”代表黑色的地板,“#”代表红色的地板,“@”代表男人所在的位置,男人每一次可以向他的前后左右移动一步,而且他只能在黑色的地板上进行移动,让你求出男人可能的移动步数;

思路:

深度优先搜索;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m;
char map[21][21];
int book[21][21];
int sx,sy;
int sum;

int nextt[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};

void DFS(int x,int y)
{
    for(int i=0; i<4; i++)
    {
        int tx=x+nextt[i][0];
        int ty=y+nextt[i][1];
        if(tx<0||tx>=m||ty<0||ty>=n)
            continue;
        if(map[tx][ty]=='#'||book[tx][ty]==1)
            continue;
        sum++;
        book[tx][ty]=1;
        DFS(tx,ty);
    }
    return ;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        sum=1;
        memset(map,0,sizeof map);
        memset(book,0,sizeof book);
        for(int i=0; i<m; i++)
        {
            scanf("%s",map[i]);
            for(int j=0; j<n; j++)
            {
                if(map[i][j]=='@')
                {
                    sx=i;
                    sy=j;
                }
            }
        }
        //printf("%d %d\n",sx,sy);
        book[sx][sy]=1;
        DFS(sx,sy);
        printf("%d\n",sum);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值