(甲)1007 Maximum Subsequence Sum (25 分)(万米深坑)

题目:

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence. (如果所有K个数都是负数,则其最大总和定义为0,并且您应该输出整个序列的第一个和最后一个数字。万米坑,你注意到了吗?)

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

就想问你,这张图眼熟不?哈哈哈哈哈,恭喜你入坑。 

题意:

给你一个数字N,后面有N个整数,让你找出来最大子序列是连续子序列,其子元素的总和最大。输出格式是:和,连续序列的首尾元素;

思路:

注意细节,注意对于全是负数情况下的输出。注意题目的最后一句:If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence. (如果所有K个数都是负数,则其最大总和定义为0,并且您应该输出整个序列的第一个和最后一个数字。)

细节代码中解释。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n;
int a[10010];

int main()
{
    while(~scanf("%d",&n))
    {
        int flag=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=0)//判断是否全是负数;
                flag=1;
        }
        if(flag==0)//全是负数就按照题目的要求输出0,数组的首元素,数组的尾元素;
            printf("0 %d %d\n",a[0],a[n-1]);
        else
        {
            int l=0,r=0,sum=0;
            int ll=0,rr=0,s=-1;//记录最大的和,这段子序列起始位置和终点位置;
            for(int i=0; i<n; i++)//注意s=-1,不然当数组中除了0就全是负数时,你的输出救会错,正确的应该输出0 0 0;
            {
                sum=sum+a[i];
                if(sum<0)//结果小于0,那么就不符合要求了,越加越小;
                {
                    l=i+1;//子区间的位置进行改变;
                    r=i+1;
                    sum=0;//注意,和也应该清零;
                }
                else
                {
                    if(sum>s)//记得记录结果;
                    {
                        s=sum;
                        ll=l;
                        rr=r;
                    }
                    r++;//记得子区间的范围应该向右扩展1位;
                }
            }
            printf("%d %d %d\n",s,a[ll],a[rr]);//输出最大的和,子区间开始和结束的元素;
        }
    }
    return 0;
}

只想说,坑坑更健康,烧烧脑,改改代码会秃得更快呢。。。。。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值